LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

myRIO Wireless Connection Issues

Hello,

 

My system is LabVIEW 2019 32-bit, Windows 10. myRIO-1900 w/ LabVIEW Real-Time 19.5.1 installed. (I installed every option)

 

I am having issues with staying connected to a myRIO-1900 that is creating a wireless network.

 

I am able to connect to the WIFI that the myRIO is creating and I am able to connect to it in LabVIEW, but about every 5-10 seconds it will lose connection and have to reconnect. This is problematic when I am trying to run a project or even trying to get the RT to deploy. I do not have this issue when I an plugged in via USB. Unfortunately, the project cannot be done over USB because of the environment it will be in.

 

I know that I have an issue with using LabVIEW when I am not on my companies VPN because it is required for the license. So, I have to disconnect from the VPN to connect to the myRIO (which I also have to do for USB connection because it kicks me off of the VPN every time I plug into a myRIO).

 

To get it to work in the meantime, we ad to install LabVIEW Real-Time 14.0.1 w/ NI myRIO 14.5 with everything installed. That has no issue with running. It is using a laptop that does not need to be connected to the VPN to run, but only has LabVIEW 14.

 

 

 

0 Kudos
Message 1 of 2
(106 Views)

It sounds like you need to talk to your IT Security people and get them to "carve out" a small restricted IP Address Space that both your Laptop and your myRIO can inhabit.  Note that the IP address that the myRIO uses through its USB connection is deliberately situated in the 172.16 non-routable IP Address Space, which should be "safe", but they may be blocking all non-routable Addresses, in which case you might not be able to use the myRIO.  See if there are other non-routable Addresses that they would allow, such as in the 10.x.x.x or 192.168.x.x range ...

 

Bob Schor

0 Kudos
Message 2 of 2
(66 Views)