LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

myRIO Autoplay

Solved!
Go to solution

Hey Guys,

 

I am trying to connect a myRIO to my laptop and everytime I do, I get this error. I made sure that have the myRIO Toolkit downloaded, but I am still getting this error message after a couple minutes after plugging the myRIO into my laptop with a USB cable. I tried plugging it in to different usb ports. I tried running it in "safe mode". It is a device that has been used before on a different laptop. I also tried to find it in NI MAX under remote devices and it doesn't show up. If there is any advice to fix this problem, it would be greatly appreciated.

 

myrioautoplayfailed.PNG

0 Kudos
Message 1 of 7
(728 Views)

A myRIO is a LabVIEW Real-Time Target, which means that it runs a Real-Time OS (a version of Linux) and has a "Front-end" that "talks LabVIEW".

 

You've not told us anything about your LabVIEW system (running on what OS?  What LabVIEW Version?  32- or 64-bit LabVIEW?) nor much about the myRIO (you might open it in MAX, expand the Software Tab, and attach a screen-shot of what this shows).

 

What kind of application are you trying to run as the startup routine?  What is "myrioautoplay"?  If this is software that you have written, then attach your VI and tell us how you built the myRIO application that you want to run as the Start-up VI.

 

Bob Schor

0 Kudos
Message 2 of 7
(685 Views)

I am running windows 10, LabVIEW 32-bit. The myRIO is supposed to open a "myRIO USB Monitor" when it is first plugged into the computer. The issue I am having is that instead of opening that, I get the error message about autoplay failing. I have attached a picture of my NImax and as you can see, it is registering that a myRIO - 1900 is plugged in using USB, but I can still do nothing with it. I think it is an issue with my computer.

 

joe112_0-1587574431815.png

 

0 Kudos
Message 3 of 7
(645 Views)

Ah, you did better than what I asked you to do -- you attached the MAX picture of your system, which clearly shows the problem (once I enlarged the image to show only the left-hand pane -- next time, restrict your image capture to just the pane with useful information, which makes the print much bigger!).

 

As I said in my previous e-mail, the myRIO is designed as a LabVIEW-RT Target, running the Linux Real-Time engine.  Here's what my laptop sees when I run MAX:

BS-myRIO.png

Notice the myRIO does NOT appear as a peripheral under "My System", but shows up under Remote Systems (along with another formerly-connected myRIO).  As you can see in the right pane, it happens to be connected via Ethernet -- if it were connected by means of the USB Cable, it would show an IP that starts with 172.something, and I think it would be labeled "USB".

 

In your system, the myRIO (plugged in via USB) shows up as a "generic USB Device" under My Systems, which means that your PC cannot connect to it and does not recognize it as a myRIO.  I'm guessing its firmware is missing, or the wrong version, or something similar.

 

Here are some questions:

  • Suppose you disconnect the myRIO and reboot your PC.  Now, with your myRIO connected to power, and your PC's speakers on, what happens when you plug the powered myRIO into a USB port?  You should hear a "Clunk" (or whatever sound your PC makes when it sees a new USB Device plug in), and a second or two later, you should get a pop-up saying something about Getting Started with myRIO, and offering to help you configure it.  I'm guessing this does not happen, but please confirm this.
  • What version of LabVIEW are you running?
  • Have you installed the myRIO Toolkit for this version?
  • Is this a new myRIO?  Have you installed the software that came with this myRIO?  As far as you know, has this myRIO worked with any computer running LabVIEW?
  • You said that this myRIO worked on another PC.  Who set that up?

It sounds to me as though the myRIO software/firmware is not compatible with the myRIO Toolkit on your Host PC.  It is a "feature" of LabVIEW Real-Time Systems that the Host and the Target systems must be compatible, which can make "mixing and matching" components a little bit tricky.

 

It is not too difficult to set up a myRIO system on a PC, but I'm not sure that all the steps are clearly written down.  I did it partly "from experience" with other LabVIEW RT targets-I-have-known.  Looking forward to seeing your comments to my questions.

 

Bob Schor

0 Kudos
Message 4 of 7
(612 Views)

When I plug in the myRIO, my computer makes the "clunk" noise and then the device icon even shows up on the taskbar. Nothing happens for about 30 seconds and then the error message (picture from the first post) pops up.

 

I am running LabVIEW 2019 (32-bit). I do have the Real-Time Module and the FPGA Module installed.

 

I downloaded the LabVIEW 2019 myRIO Toolkit. I actually uninstalled it and reinstalled it recently just to be sure.

 

This is not a new myRIO, so I do not have any of the software that came with the myRIO. I have never run a myRIO on this computer before, but it has been run on other computers. I also downloaded the myRIO Toolkit to a different laptop and it at least opened the USB Monitor. I wasn't able to connect to it because I didn't have LabVIEW on that laptop, just the myRIO Toolkit. 

 

I asked the person who would've used it last and he said there were never any problems for him connecting to it. I don't know what version of LabVIEW he is running.

0 Kudos
Message 5 of 7
(608 Views)

Joe,

     I suspect the problem is that the myRIO Firmware (which seemed to run on an older version of LabVIEW) might not be compatible with the current version of LabVIEW.  A "fix" is to Flash the firmware, but this will render it incompatible with the older version of LabVIEW, so you may need to ask your colleague if that's OK.

 

     I sent you a Private Message with some more details.

 

Bob Schor

0 Kudos
Message 6 of 7
(582 Views)
Solution
Accepted by topic author joe112

It has been a while since I have posted to this but the problem has been solved. It was an issue with the initial installation of LabVIEW 2019. When I uninstalled everything and reinstalled it, I was able to get it to work. 

0 Kudos
Message 7 of 7
(54 Views)