Showing results for 
Search instead for 
Did you mean: 

myRIO-1900 Error code: -63044. The RIO server could not be found on the specified remote device

I am trying to run a simple on my myRIO-1900 device to confirm successful communication. I have been able to deploy multiple vi's to the RT on the myRIO, but any attempt in trying to compile and run FPGA code results in Error code: -63044: "The RIO server could not be found on the specified remote device."


We've tried updating the firmware on the myRIO based on the "Upgrading Firmware on my NI Linux Real-Time Device" article on the National Instruments website, which says we just need to go to the correct folder (for myRIO-1900 that would be the 762F folder). When I look in that folder through windows file explorer I see two .cfg files which looks similar to how it should be in the article. However, when I go through the Update Firmware button in NI MAX, the folders appear empty. Instead of looking for .cfg files, the explorer only allows searching for .lvbitx files. Is there some sort of software update I need to fix this? And would updating the firmware actually fix the error code -63044.


I have attached screenshots of both the error message and the firmware search from NI MAX. I also have a screenshot of the extremely simple code to test if the FPGA was working correctly.


I am running LabView 2017 on Windows 7 and the device is a NI myRIO-1900.


Any help would be greatly appreciated!

0 Kudos
Message 1 of 7

Hi Jason46,


Have you seen the document below? In addition to checking the Firmware, you will also want to check that the software on your host and target and compatible.


Error -63040 When Attempting to Run an FPGA VI on CompactRIO 



Technical Support Engineer
National Instruments
0 Kudos
Message 2 of 7

Hi ErikaB,


I tried to follow your link to the document below but wasn't able to.

I just went through and reinstalled all National Instruments software in the following order: LabView, modules, toolkits, and then drivers, and am still having the same problem. I also reset the configuration data in MAX and formatted the disk on the myRIO with the same -63044 error.


I'm using LabView 2017 Professional Development System on Windows 7 (Service Pack 1) with the myRIO-1900. The myRIO has the most recent 4.0 May 2017 software version installed. From what I've been able to find, this should all be compatible together. Is there something else I need to look at to determine if its compatible?




0 Kudos
Message 3 of 7

Sorry about the bad link. Here we go again:

Error -63040 When Attempting to Run an FPGA VI on CompactRIO 


What version of the NI-RIO driver do you have on the myRIO? Other than LabVIEW, what other software do you have on the myRIO? Some more information about what software is necessary is below.


Required Software for NI myRIO


Hope this helps!

Technical Support Engineer
National Instruments
0 Kudos
Message 4 of 7

I have version NI myRIO 17.0.0 on the myRIO. As for the software I have installed on the myRIO, I have attached a snapshot of what MAX shows for all the software I have installed on the computer and on the myRIO.

0 Kudos
Message 5 of 7

Hi Jason,


Thanks for the screenshots.


Going back to the firmware, are you in the 64-bit or 32-bit version of the Program Files folder? Check if you can find this directory in the Program Files x86 path. Since this is a clean install of the driver, I would anticipate that firmware would be up to date, so I am not sure why this is not showing up. If you try to update within MAX, what folder are you directed to? Is the firmware config available there?


For the deploying of the VI,

  1. Within the project, how are you deploying the FPGA VI? Can you send a screenshot of your project set up?
  2. Within MAX, in Remote Systems >> your target >> Software >> NI-RIO >> NI-RIO Settings (on the right panel), there should be information about the RIO Server. Is a static port set up? How are the Devices with Remote Access configured?


Hope this helps us getting moving in the right direction.


Technical Support Engineer
National Instruments
0 Kudos
Message 6 of 7

Hi Erika,


This is the path I've been looking for the firmware at: C:\Program Files (x86)\National Instruments\Shared\Firmware\cRIO\762F. The only thing in that folder is myRIO-1900_4.0.0.cfg. I've updated the firmware of the myRIO with that cfg file multiple different times as I've been troubleshooting, however on one of the error solutions somewhere I believe it says to update the firmware image file, which I can't do because there's no image files in that folder. I've attached screenshots of both of the "Update Firmware" selections. One searches for .cfg and the other searches for .lvbitx.


1) I've attached the project with the FPGA in it. It's super simple and we've just been using it to try to test if the FPGA is working. It throws the -63044 error code when we try to run the FPGA, but we’ve seen that error elsewhere even when we aren’t running code. It’s appeared every time we boot up the myRIO and hit the “Launch the Getting Started Wizard.” It gets through every step in the wizard including downloading software if we’ve formatted the disk, but right before it’s about to test the onboard devices it displays the error. We’ve never been able to get to the testing the onboard devices screen when booting up the myRIO.


2) I've attached a screen shot of the NI-RIO settings with the RIO server. We haven't done anything with the Settings or Server here, but it does show the Error -63044.






0 Kudos
Message 7 of 7