LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

lvanlys.dll 

请教各位大侠,我安装了labview8.20中文试用版,本人刚学这个软件,从开始打开模板准备打开模板是出现lvanlys.dll初始化例程失败,不知道为何。请各位大侠指教
0 Kudos
Message 1 of 9
(5,101 Views)

同问!

0 Kudos
Message 2 of 9
(4,065 Views)

The oriinal question was 8 years ago. Are you still using LabVIEW 8.2?

 

The current evaluation version is LabVIEW 2013, so try that!


LabVIEW Champion. It all comes together in GCentral GCentral
What does "Engineering Redefined" mean??
0 Kudos
Message 3 of 9
(4,050 Views)

I'm using LabVIEW  2013 now, but I encounter the same problem.

Now I'm reinstalling my LabVIEW for I can't find another solution.

0 Kudos
Message 4 of 9
(4,033 Views)

I have tried labVIEW2013 and labVIEW2012, but still the problem exists. Don't know how to fix it.

labview1.jpg 

 

搜狗截图20140429125058.png

and it just keep popping up for dozens of time until it finally comes to an incomplete and blank component:

搜狗截图20140429125320.png 

 

 

 

0 Kudos
Message 5 of 9
(3,965 Views)
Can you translate the messages in those pop-ups?
0 Kudos
Message 6 of 9
(3,946 Views)

Hi, thank you for your reply!

 

I have just fixed the problem!  I have replaced all the content in "D:\Program Files\National Instruments\Shared\MKL" with another copy from my classmate who has successfully installed labVIEW2012. And it worked! 

搜狗截图20140430001155.png

 

The problem was that when I tried to add an "simulation signal" component in the Block Diagram, an error message kept popping up indicating an error in  loading "D:\Program Files\National Instruments\LabVIEW 2012\resource\lvanlys.dll"  and DLL initialization examples failed. These messages kept popping up for dozens of times and finally a blank "simulation signal" component with no available attribute came up.

 

I guess the reason of this problem is that  I have uninstalled labVIEW2013 on this computer before. When I searched the Internet I found that there is  something wrong with the NI uninstallation and after you reinstall it there will be all kinds of problems. 

 

Anyway it is so great that my labVIEW finally works, after I have spent this whole week trying all kinds of methods I can find on the Internet  to fix it !

 

0 Kudos
Message 7 of 9
(3,916 Views)

Sounds like a bad install.  In the future if you see something like this it is best to perform a repair install, instead of copying files from other computers that you assume haven't been tampered with.

0 Kudos
Message 8 of 9
(3,907 Views)

Yeah, and I will be more careful with the installation and uninstallation of softwares.

0 Kudos
Message 9 of 9
(3,892 Views)