Showing results for 
Search instead for 
Did you mean: 

labview no longer runs after windows update

Go to solution

Running Windows XP 32bit w/ Labview 2012 SP1 - Windows auto-updated on May 11, 2013.  After update, Labview hangs on startup, nothing fixes it.  Tried restarting and all the usual nonsense.  You can open VIs, but then the CPU goes into a state of either 50% or 100% usage (seems to be random) and Labview just hangs w/ hourglass icon and never responds.  I can open NI MAX and querry various instruments, but Labview itself (either startup or any VI) just hangs.  

I need fix ASAP, scientist on very tight deadline, can't wait for NI to open their doors on Monday morning.


PLEASE HELP!!!!!!!!!!!

0 Kudos
Message 1 of 22

Tried Labview 2012 SP1 (32 bit) f2 patch - but the patch tells me there is nothing to install.

0 Kudos
Message 2 of 22

Attempting repair install now ... 

0 Kudos
Message 3 of 22



Have you tried to repair the current LabVIEW installation?


What are your computer specifications? Do you have unusual hardware (many CPU cores, certain AMD processors)? What were the updates?

0 Kudos
Message 4 of 22

This happened to me not too long ago. A clean install (after 3 tries) fixed it. 

My plan for future proof. No internet access on my work laptop and no more windows update (burned many times with other apps.). 



0 Kudos
Message 5 of 22

Repair install did not fix anything - thanks for the response.


My specs are:


HP workstation

Xeon CPU 3.8 GHz (single core)

3.25 GB RAM

Win XP Prof SP3 (32bit)


I suspect this is a special build by HP for my workplace.  Computer has always run Labview without problem, first time I've encountered an issue.  Perhaps the Win Update has simply made Labview incompatiable with XP, and since the update was only applied yesterday I'm the 1st person to report it.

0 Kudos
Message 6 of 22

There are two recent updates:


Hotfix for Windows XP (KB9545505-v5)  5/10/2013

Hotfix for Windows XP (KB961118)  5/11/2013


I could look these up, but I'm not a Windows Guru and I doubt I would understand how the changes matter.


I'll try the clean install, see if it works.

0 Kudos
Message 7 of 22

Support pages for the updates:


One updates .NET Framework 3.5 SP1, the other MS XPS.  I do not know enough about how these featurs would affect Labview to diagnose.

0 Kudos
Message 8 of 22

I am not really technically knowledgeable in windows OP, but I suspect that you may not be able to solve the issue without involving NI (for which you do not have time). A clean install may be a shortcut to resolving the issue. 



0 Kudos
Message 9 of 22

Just another random suggestion: have you tried renaming the existing labview.ini file?

0 Kudos
Message 10 of 22