LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

labview drivers for Prisma QMS

Dear Gernot,

 

I just wanna know how I can connect to PrismaPlus according to my knowledge there are few methods:

 

1. NI - DSC

2.Softing Need DataFeed OPC Suit.

3.Softing Toolkit with .Net

4. Data Socket.

5. Quadera

 

I am wrong please correct me.

 

Furthermore,  I wanted to access and control QMG220 through LabVIEW in this regard I need your help for the solution of this problem.  

How can we access the quadera built-in OPC server because I have the license version of quadera software? In one of your email i saw you attached a couple of pictures of Quadera OPC server but if I open the quadera software i can't found such interface of OPC server. 

 

Regards,

Tufail 

 

0 Kudos
Message 71 of 95
(1,462 Views)

Dear Tufail

 

You are absolutely right with the 5 possible methods.

 

When try the OPC connectivity from any third party opc API vendor and you are using a remote OPC from labview please dont forget to add the line.

 ole.AuthnLevel = 1 to your labview.ini file. 

 

The QUADERA software is only  OPC client to access the Prisma+ build in OPC server. When you use your own software you need to build a OPC client (or use a existing demo progam OPC client) to access the OPC server to write and read OPC variables.

 

The attached pictures are typically showing the OPC demo client from Softing. They have nothing to do with Quadera. 

In the Softing Demo client you can view remote OPC items. If you are correctly connected to the Prisma+ OPC server you can see the Items as shown in the screenshots.

 

 

Just to mention we want to inform you that Quadera will not work after a windows upgrade to Windows 10, 1803. It just "kills" the windows installation at all so that no other installer on the windows system will work until you reinstall windows.

After long discussions with pfeiffer it seems there will be no fix at all ;(

Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
Message 72 of 95
(1,460 Views)

Dear all,

I am not suprised to see that i am not the only one struggling with that.
I develloped a full labview interface to control prisma plus and Hiquad rgas with labview. That i provide as exe to my collegues.


Past weeks i ran a installation test campain to see if my code would be installed properly on windows 10 machine as we don't get W7 machine anymore at work.

 

At start i didn't manage to install my application and i couldn't figure out why.

After many trials on W10 virtual machines, I understood that it was linked to the Quadera installation. 

 

As Tufail mentioned, Pfeiffer also told us that , yes you can use Quadera on W10, but it is not officially supported but at this time, i was not told that Quadera would mess up my computer on W10...

 

The factual problem is that the installation of Quadera on W10, corrupts some windows registers, preventing the installation later on of other program e.g. labview. From what i have seen, It is most likely linked to a corruption of registers attached to Visual C++ redistribuable or something like that, but i could not find wich registers are damaged yet. Unustalling Quadera doesn't work. And i tried unustalling the C++ redistribuables but i could not reinstall them after.

So far i don't have a solution but there is a work arround if you don't have the latest W10 patch installed on your machine.

 

 

The way to fix the installation corruptions after Quadera installation is to patch your machine with the latest past from W10 after Quadera was installed.:

 

- ckeck that you are not using the latest windows patch .  ( i had patch 1709 when i installed quadera  then i installed the 1803 patch)

you can use the winver command to get it.

 

- install quadera.

- reboot the pc

- check that quadera works.

At this point you may have issue installing other application, for me it was labview not installing.

 

- go on microsoft website, download and install the latest patch.

https://www.microsoft.com/fr-fr/software-download/windows10

 

if your installation freeze at 0% kill the installer window from the task manager, go on the website and download it again. the second time it will go through. The patch installation took several hours to be done in my case but once done, i could install Labview. ( my machine was then patched to W10 1803 patch.)

 

 

Also regarding quadera and W10, if your Quadera do not work, check the dcom config.

 

For quadera to run, make sure the default authentification for dcom of your pc is set to ''none''  and that you have a user called ''ANONYMOUS LOGON" with local and remote access  allowed for the access permission.

I lost a lot of time trying to understand what was wrong, and i figured out that the check dcom config tool comming along with Quadera was saying that all was ok, while it was not true.

 

What I didn't know is that pfeiffer actually sent us a document about installing on windows 10 where the says that you need to manualy do some part of the dcomcnfg before running it. As i didn't know that, i lost quite some time to figured it out myself before some colleagues shows up with the explanation paper.

 

 

 

I am waiting for IT support colleague to come back from hollidays to have a look with him to find a proper fix, because i am not able to fix it by myself.

I hope i will know more by the end of the month.

 

if i find a solution i will share it.

 

I hope this helps.

Please if you find a solution share it too.

 

Regards,


Antoine

 

 

0 Kudos
Message 73 of 95
(1,454 Views)

Hi, 

I also used NI-DSC to read feom the OPC server of the PrismaPlus, I just followed the tuto made by Antoine some posts ago, i recommend it.

 

P.S.: thx again Antoine!

0 Kudos
Message 74 of 95
(1,451 Views)

Hi again,

I just realized i mentioned comment from Tufail in my previous post, but it was actually comment from Gernot Hanel that i wanted to refer to.

 

BTW, Gernot thanks for your effort trying to push pfeiffer to do something for that. I am forwarding the info to all my collegue because many of them install quadera, and then don't understand why they cannot do any other installs and just send their pc to be formated...

 

At start I wanted people to be able to use either Quadera or my Labview application ( it a universal interface that offers the control of 4 different models of RGA throught the same application, including 2 from pfeiffer, one from Hiden, and a virtual RGA ).

But the way i see it, if pfeiffer does nothing, and there is no work arround, i think i will try to get rid of Quadera install and do the port opening, dcomcnfg and Server maping all by myself ( in a automated way ) so i don't need quadera installation on the pc to run my labview. I t was convenient to have it like that up to now but knowing the issue we have now, I am tempted to jump the step.

 

best regards,

Antoine

 

 

 

0 Kudos
Message 75 of 95
(1,444 Views)

Dear Antoine

 

I also happy to know that we are not the only one struggling with the Prisma+.

By the way Pfeiffer has a new software called: PVMassspec which should work for Prisma+ abut they don't recommend it because there are not all features included.

 

Over all it is horrible…. as we need to support our older instruments too.

 

By the way i have a question.

 

What basis of your OPC communication are you using NI_DSC module, SOFTING (DLL or .NET) or a different one ?

 

We try to so only the needed things up to now because we were moving towards Time Of Flight Massspectrometry with different hardware and software interfaces.

Also different problems;)

 

Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
0 Kudos
Message 76 of 95
(1,433 Views)

Hi.

We figured out that the only problem between Quadera and W10 is the DCOM authentification level being set to ''none''.

Problem is that if it is set to none, you get an error 1935 when you install other apps.

Looking at the registry changes with a spy tool, it doesn't seems actually that Quadera is damaging anything.

Also this is why ununstalling Quadera did not help to fix the problem, as the Dcom authentification level is left to none....


After Quadera installed if you go on the Dcom config and change it back to ''connect'' it all works fine and i could installed labview.


So finally it seems that Quadera should work fine now on W10. ( for now )

On W7, i think Quadera installer was able to change the authentification back to connect.
for some reason it is not doing it on W10. So that is why we got all this problems.

 

My colleague responsible for rgas gave a try to PVMasspec and prisma + but as you said some features are missing there, which make it not conveniant to use.
 

Regarding OPC communication for Prisma plus and Hiquad,  I go through the dsc module so i can use the specific vis of the palette to perform a subscription to read the data on value changes, and I use the datasocket vis to write.

 

The fisrt step is to create the process and the OPC Client ( i do create automatically the process through the dsc vi : create process  and the client with the Express vi I/O server.)

After that you can use datasocket to both read and write to the variable with the process name, server name and variable name.

 

To set up the subscription , I use the DSC vis that  allow me to get a ''shared variable value change notification'' reference, that i can then register as user event, and get the data directly on the event structure when they have a value change.

 

Once i receive a new data, then just put all the new info in a global variant data base so any other modules can access the up to date data.

this way I subscribe to like 90 items of the rga and get everything anytime.

 

There is just a work arround to do for getting a mass scan, (due to from my point of view of a bad implementation on the server). For some reasons you cannot get the raw mass scan data package if you are already subscribing to other variables..... the package is just not sent by the server.

meaning you have to unsubscribe to all your variables, so you gan get the specific variable with the data package. And then when the measurment is over, you have to re-subscribe again...

 

 I would say the easy solution to start with is  to create the process and the client from the distributed manager, so you don't need the vis to do it programatically, then you can also use the network shared variables to read and write to it directly.

This was how i did it in the first version of my application. ( that is described some post earlier in the forum ). but i am not a fan of having global variables all over the place, and i also think that when you have a OPC server, it is a bit stupid to do polling when you could subscribe.

 

In all case you need to run the .reg file that you can fine on previous posts, because without it labview is not able to get the definition of the server item list, so you can't create the proper I/O client.

I hope this helps.


let me know if you need more infos.

 

Regards,
Antoine

Message 77 of 95
(1,417 Views)

Dear Antoine

 

This seems to be perfect.

My collegue will try it right now. 

We will come back to you in any case with our results.

Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
0 Kudos
Message 78 of 95
(1,414 Views)

Hi Antoine,
I'm the colleague of Gernot and tried it out.

I've installed Quadera 4.62 on a 64 bit Windows 10 Pro 1803

 

After installing the Quadera, I checked the Dcom setting (cmd -> Dcomcnfg -> ... ) and you're right, the DCOM authentification level was set to "None".

So I set it to Connect. I tried then to install some other software and it still made an error "invalid windows installer file or something".
But a few minutes later I was able to install it and other software without any problem ... ?

The only thing is now that Quadera cannot find the Prisma+ Quad. (Menu -> Device -> Device Setup... -> Search)

 

My softing OPC software can access Prisma+ items without any problems.

 

Have you managed it to connect Quadera to Quad in Windows 10?
It's also strange that the "Check Dcom settings" tool of Quadera still means that Dcom Level is actual None - but it isn't...

Thanks
Hans

0 Kudos
Message 79 of 95
(1,407 Views)

Hi Hans,

I managed to have it working yes, but I had to check all the dcomconfig manually because i saw also that  the checkdcomcnfg tool says that it's all ok , while it is not.

 
 
In my case the Remote acces was seen as ''allow - ok '' but actually it was not set in the com security.

You can Check the Access permissions for the ANONYMOUS LOGON .

 

Also you can check if Quadera and the QMS detection are set as exeption rules for the firewall.

 

it took me a moment before having it working but it finally worked.

 

Can also be that you need to be on the same subnet to be able to detect it. ( at least the first time )

 

There are several time that we know the IP of the RGA but quadera can't see it.

 

Then we have to go and set the IP of the PC to be fix IP with the same Subnet, just changing the last digits of the IP.

EG : RGA ip : XXX.XXX.XXX.10   --> PC IP set to XXX.XXX.XXX.11

 

In our cases we have both local network for the RGA ( throught ethernet to usb converter ) and normal network for work in the network card of the PC.

 

When we cannot detect the RGA, we have to disconnect the work network because otherwise it never works. I am almost sure that the the detection tool just try to find the RGA on the wrong network when you have two network defined.

Usually once the RGA have been detected once then it works the next times.

 

I don't really remember us managing to have RGA connection through network with Quadera. ( i mean not local connection ). But it works perfectly fine with labVIEW. I had to set up a dedicated virtual machine with my labview software on it for some colleagues who cannot have a direct connection to the RGA, and they only use that, because it was easier than dealing with Quadera.

 

Personally, i gave up on using Quadera as my labview does almost all what Quadera can do but with added homemade features. I just have to deal with Quadera for colleagues that need to use it, as my Software is not yet provided as official tool to all the users at work.

 

Do you have the RGA as direct local connection or throught network ?

Let me know if you managed or not to have quadera working.

Regards,

Antoine

0 Kudos
Message 80 of 95
(1,404 Views)