LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

labview drivers for Prisma QMS

Hi Jeremy,

 

I don't know why you can get data with the ni server explorer and not with labview.

What i know is that if if you missed one of the steps during the install it may not work. But I assume if you can see things in the ni server explorer as i can ( see attached ) then you should also be able to see it in Labview ( see atached )

 

Also for the QMA-220.reg file after you edit it with your ip adress you just nedd to double click to run it.

 

I have Quadera 4.6, i don't think i have a special version. 

 

I am running labview 14 (32 bit version). 

 

one thing is that also if you reboot your device it may change ip if this one is getting ip dynamically.

Then i think i checked and i am not sure if you need to update the ip and rereun the regt file if your device ip changed.

but ok just in case you could redo it if needed.

 

also once you are able to see the OPC object in labview, i would recommend that ytou do a simple dummy vi were you just look at the sem voltage because this value is always moving and it is a good indicator that the system is alive and updating.

 

 

 

Regards,

 

Antoine.

 

Download All
0 Kudos
Message 51 of 95
(1,263 Views)

Hi all,

 

Just as an additional information, i just tried with the HiQuad ( QMG700 ) and it works exaclty the same as for the Prisma plus with labview. ( using the solution i proposed a couple of post before).

 

I didn't even need to change any settings. ( I even left the same name QMA220-DA as Prog ID, and i didn't need to change anything on the reg file).

 

Regards,

 

Antoine.

 

 

0 Kudos
Message 52 of 95
(1,098 Views)

Hi,all  !!

Jeremy,

Have you fix your troubles with quadera and Labview? I have the same promblem and no idea how to fix it up.

 

Antoine,

I have tryed to use your receipe, and only one step i can't performe.

"On the Map Network Server select the server QMG220-DA on the list and add your machine IP addess.
a new item appears on the list as QMG220-DA on 'your_machine_ip'."

i created the  QMG220-DA on 'my_machine_ip', but cann't connect to it. Could it be the reason of my trouble same as Jeremy?

 I create the dummy VI to read HighVoltage and have "no data", same as Jeremy.

Best regards, Andrey

0 Kudos
Message 53 of 95
(995 Views)

Hi Andrey,

 

From what i understand you are triying to connect to the RGA using NI server explorer as a client.

If the dcom settings and configuration is ok, and if you have added the register with the reg file, you should have acces to a server called QMG220-DA from the server explorer

To see that, from the NI server explorer window on the list on the left , if you right click on "computer" and do "map network server" you should be able to see a process on the server list that will be called QMG220-DA. ( see attached ).

If it is not the case then you should verify if all the configurations steps were performed.

 

If you can see it :

Select this one as your server choice and put your device ip on the machine name below.

 

This should have created a new item on the list of the server explorer window ( the list with semaphore close to each object) called QMG220-DA on " you machine IP"

if yes, you just right click on this one and select wizard. go next and then you should see the list of all the opc items.

after that you should be able to connect and receive data from the RGA into the server explorer.

 

Going with the server explorer in the end is only to help you verify that the communication is ok.

If you can read data with the server explorer client it should work later when you will use a Labview opc client.

From what i have seen, if it doesn't work with the server explorer, there is little chance to have working with labview.

 

I don't know if this answer to your question.

 

Please have a look and keep me updated on what you have so that i can try to help you to solve this.

 

Best regards,

 

Antoine

0 Kudos
Message 54 of 95
(980 Views)

 

Hi again,

 

I just had another look at your post and i realize i just read to quickly the first time so i probably don't reply to your answer in my comment.

 

It could be that some steps is missing in the installation.

 

I would recommand that you try to connect with another client like matrikon OPC.

If you manage with Matrikon we can exclude that there is a dcom issue. This will already give us more information on what could be wrong or at least on what is not wrong. when i was doing the install i remember that i some point it worked with matrikon but it wasn't working yet with the NI server explorer, but i don't remember what I did to solve this.

 

I will probably soon redo the installation in a new machine so i will be really carrefull at this moment to verify what need to be done and i will document it , but so far, i did the installation a couple of times following the same installation procedure and i had it working directly.

I also sent the same procedure to someone who contacted me and this person managed to have it working too.

Please give me some feedback and i will do my best to see if i can find the solution.

 

Regards,

 

Antoine.

 

 

Regards.


Antoine

 

0 Kudos
Message 55 of 95
(969 Views)

stoad57 escribió:

 

Hi again,

 

I just had another look at your post and i realize i just read to quickly the first time so i probably don't reply to your answer in my comment.

 

It could be that some steps is missing in the installation.

 

I would recommand that you try to connect with another client like matrikon OPC.

If you manage with Matrikon we can exclude that there is a dcom issue. This will already give us more information on what could be wrong or at least on what is not wrong. when i was doing the install i remember that i some point it worked with matrikon but it wasn't working yet with the NI server explorer, but i don't remember what I did to solve this.

 

I will probably soon redo the installation in a new machine so i will be really carrefull at this moment to verify what need to be done and i will document it , but so far, i did the installation a couple of times following the same installation procedure and i had it working directly.

I also sent the same procedure to someone who contacted me and this person managed to have it working too.

Please give me some feedback and i will do my best to see if i can find the solution.

 

Regards,

 

Antoine.

 

 

Regards.


Antoine

 


Hi stoad57,

 

I have the same problem here. I can see my OPC server and add it to Labview. In  server explorer also in other OPC clients I can see values changing, but when I try to see something on LabView, I get no data...

0 Kudos
Message 56 of 95
(820 Views)

Hi,

Sorry for the delay in my reply.

 

One thing i noticed since my last post is that there are issues trying to run the server explorer at the same time as LabVIEW ( LabVIEW is sometimes not getting data if the server explorer has been launched first ). I would recommend to check with matrikon instead if you want to access from two clients at the same time. ( Also the server explorer is not a supported tool anymore since windows xp or something like that but i noticed it not so long ago).

 

Then what can happen also is that the ni variable engine is having issues or is turned off.

You can see that with the distributed manager:

 

- If when you create a new process on the distributed system manager, it does not show up on the list then the you need to reboot the NI Variable engine.

 

You can find the process as " Ni Variable engine " in the service list"  ( the process is actually named tagsrv.exe and it is here : "C:\Program Files (x86)\National Instruments\Shared\Tagger\tagsrv.exe" )

 

You should be able to see from the distributed system manager the opc process with live values has shown in the image attached.

 

I don't know if this is the reply to your question,

 

maybe also check the following point : 

 

On the component service windows go under Computers/mycomputer/ Dcom Config and find on the list the item called OpcEnum and verify the settings ( right click --> properties) as :

 

- General tab : Authentication level = none 

- Location tab : Run app on this computer is ticked.

- security tab : all three set to customise with :

          launch and activation permission having  everyone, system, interactive with all permissions allowed.

          access permission with everyone and self with all permissions allowed.

          endpoints : default system protocols on the list.

          identity : the system account ticked.

 

do the same for the QMG register :

 

find QMG220-DA-000 on the list and edit properties :

General tab : Authentication level = default

Location tab : Run app on this computer is ticked.

security tab : launch and activation permission set to use defaults

                     access permissions set to use defaults

                     configuration permissions set to customise and then with configuration as :

                                  system, user admin, creator owner have all allowed permissions.

endpoints : default system protocols on the list.

identity : the launching user

 

then try running your application with the firewall OFF also. maybe you are missing some firewalls exceptions.

If it works like this then you will have to add later on the correct firewall exception so that your code works with the firewall on.

 

I hope with this you will solve the problem.

Feel free to contact me if you still cannot solve the problem or if my explanations were not clear enough.

 

Regards,

 

 

0 Kudos
Message 57 of 95
(811 Views)


stoad57 escribió:

Hi,

Sorry for the delay in my reply.

 

One thing i noticed since my last post is that there are issues trying to run the server explorer at the same time as LabVIEW ( LabVIEW is sometimes not getting data if the server explorer has been launched first ). I would recommend to check with matrikon instead if you want to access from two clients at the same time. ( Also the server explorer is not a supported tool anymore since windows xp or something like that but i noticed it not so long ago).

 

I think that it was the problem. I had more than 1 client running and that was yesterday. Today i tried again and its solved, maybe NI variable engine was reseted and now works perfect.

 

Thanks for your advice, you are so helpful!

0 Kudos
Message 58 of 95
(804 Views)

stoad57 escribió:

Hi,

Sorry for the delay in my reply.

 

One thing i noticed since my last post is that there are issues trying to run the server explorer at the same time as LabVIEW ( LabVIEW is sometimes not getting data if the server explorer has been launched first ). I would recommend to check with matrikon instead if you want to access from two clients at the same time. ( Also the server explorer is not a supported tool anymore since windows xp or something like that but i noticed it not so long ago).

 

Then what can happen also is that the ni variable engine is having issues or is turned off.

You can see that with the distributed manager:

 

- If when you create a new process on the distributed system manager, it does not show up on the list then the you need to reboot the NI Variable engine.

 

You can find the process as " Ni Variable engine " in the service list"  ( the process is actually named tagsrv.exe and it is here : "C:\Program Files (x86)\National Instruments\Shared\Tagger\tagsrv.exe" )

 

You should be able to see from the distributed system manager the opc process with live values has shown in the image attached.

 

I don't know if this is the reply to your question,

 

maybe also check the following point : 

 

On the component service windows go under Computers/mycomputer/ Dcom Config and find on the list the item called OpcEnum and verify the settings ( right click --> properties) as :

 

- General tab : Authentication level = none 

- Location tab : Run app on this computer is ticked.

- security tab : all three set to customise with :

          launch and activation permission having  everyone, system, interactive with all permissions allowed.

          access permission with everyone and self with all permissions allowed.

          endpoints : default system protocols on the list.

          identity : the system account ticked.

 

do the same for the QMG register :

 

find QMG220-DA-000 on the list and edit properties :

General tab : Authentication level = default

Location tab : Run app on this computer is ticked.

security tab : launch and activation permission set to use defaults

                     access permissions set to use defaults

                     configuration permissions set to customise and then with configuration as :

                                  system, user admin, creator owner have all allowed permissions.

endpoints : default system protocols on the list.

identity : the launching user

 

then try running your application with the firewall OFF also. maybe you are missing some firewalls exceptions.

If it works like this then you will have to add later on the correct firewall exception so that your code works with the firewall on.

 

I hope with this you will solve the problem.

Feel free to contact me if you still cannot solve the problem or if my explanations were not clear enough.

 

Regards,
 i


 Hi Stoad, I have problems here. Last comment I made, I was talking about the simulator... Im a bit novice in this world and thought that my problem was solved...

So now, the real problem : I achieved to receive data from the simulator, but when I try to use the real QMG220, I cant receive anything. I can see the folders on LabView and create bound variables, but cant see data.

Using the softing opc client or the NI ServerExplorer, I get error 80040154 (Class not registered). At first, on Softing I got error 8007005 but solved it with DCOM permissions .I've made all the registry entries that you told us and now I have that 80040154. On NI serverexplorer, the same error (class not registered). I've made the changes in booth regedit and sysWOW64. So I dont know what is the problem here... could you please tell us wich version of Windows you are using?

 

I think that could be problem of 64bit OS, but LabView, NIserverexplorer and even Softing OPC arerunning 32-bits process... Its strange

0 Kudos
Message 59 of 95
(774 Views)

Hi, sorry for thé delay on the reply.

On my installations I am running on both windows 7 and windows 10 64 bits os. My labview application was done with labview 14 (32 bit version) and was moved to labview 16. 

i think your error error codes can come from a issue on the opc server itself. It is possible that it crashed and you need to reboot your device ( and wait a couple of minutes). try to see if you can connect with quadera. If not that is a sign that you need to reboot. Also you must wait a couple of minute after a reboot of your device before attempting to connect otherwise the server is not ready yet for communication and everything is going to go into a bad state again.

From what i have seen i don't know if there are issues linked to 32 or 64 bit uses.

 

Anyway I would recommend to check if quadera first works then with matrikon as a first step to see if you can connect to it and if that works I would try to create the process then the client with the distributed system manager and see if I can have data that alive there.

 

If matrikon is able to connect then it means that your dcom settings are ok. So then it is more a problem of having labview to connect. 

 Maybe also verify that all is correctly set up using the small tool that comes along with quadera? ( the checksettings tools or something similar ) and verify that you did install the register. (Qmg220-da.reg) 

The process that you have to use should be seen as qmg220-DA-000 or something like that ( without the -sim behind because that is for the simulator ).

On thing to know is that the simulator is running on your PC while the real opc server is running on the embedded windows of the that.

I am sorry but I am not really able to help more than that for now. I am on the other side of the planet for 2weeks without computer. Still i hope my answer is useful to you. I will try to help you if possible when I have access to wifi on my phone.

cheers.

stoad.

 

0 Kudos
Message 60 of 95
(769 Views)