LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

labview drivers for Prisma QMS

Here is a link for a demo version from.

 

I think the order of magnitude is in the 1000 s of € range depending if it is a single license or an unlimited distribution license.

 

 

http://industrial.softing.com/en/products/software/opc-development-toolkits/opc-classic-development-...

 

Best regards

 

Gernot

Gernot Hanel
IONICON Analytik Gesellschaft m.b.H.
0 Kudos
Message 41 of 95
(1,868 Views)

Thanks!

0 Kudos
Message 42 of 95
(1,866 Views)

Without TBN40.dll  ,I still have no way to setup connection with RGA by LABVIEW....

Have other  way to setup RGA with LABVIEW  without Softing?

 

Thanks

0 Kudos
Message 43 of 95
(1,840 Views)

Sorry,

Help me, please. Tell me why the lamp "tune" is shining now on my Prisma QMS200?

As a result, there is no connection.

Thanks a lot.

0 Kudos
Message 44 of 95
(1,813 Views)

 

hi all,

I will share here my knowledge hoping it helps a bit.

From what i've done i can control a QMG 220 via labview quite easily via the OPC server of the device using labview as opc client. setting up the code is easy since you just have to create an opc client from labview. there is a communication protol from the manufacturer go to the download center of the manufacturer and search for qmg 220 protocol you should find the communication protocol with all the names of the opc variables and some exemples in the end of the document.

https://www.pfeiffer-vacuum.com/en/info-center/download-center/

the tricky part is to be able to setup the communication between labview and the device ( actualy being able to see the OPC server of the device in labview. )
here are the steps but you will need to have the Quadera already installed because this will requiered some parts of its installation to work and for labview programming you may need the dsc module.
There are then several steps :

First of all make sure that :

your device is set up on the network,
you can ping it
you know its IP Adress
Then follow the procedure.

a. add OLE Autorisation in the labview ini file

- Go to C:\Program Files (x86)\National Instruments\LabVIEW 2014* (*LabVIEW 20XX if not using labview 14) and open the labview.ini file with the notepad
- Edit the LabVIEW ini file and add "ole.AuthnLevel=1"

b. Take the attached file open it change IP for yours .
Remove the comment and change its extension for .reg then run the registry file. It is a necessary step to have labview able to see the opc server of the device.

c. add inbound rule to the firewall

go start button -> control panel then type firewall on the search bar and open the firewall panel
go advance settings.
add new inbound rules or set then as followed :
Open inbound rule in windows firewall UDP 23269 “QGM detection port"
Open Inbound rule in windows firewall TCP 135 “DCom port"
you can verify the Required TCP port with the service tool you should have in your quadera installation but they should be the same i guess

Check the DCOM settings

Check the following instructions and make shure you've gone through all the steps especially steps 3 &4
http://www.sytech.com/download/OPC_and_DCOM.pdf


verify settings via the tools in quadera :

Run the CheckSettings file
Run the check dcom and firewall settings and verify that you have : QMG detection port udp 23269 open and ok
At this point you might need to reboot your machine. then at this point all should be ok to connect to the device.


I would recommend you to try to connect to the device opc server using the labview NI server explorer. http://www.ni.com/download/server-explorer-2.4.1/569/en/

On the menu in the list should be visible an item called QMG220-DA. If this does not appear, you might have forget one step on the procedure above.
Right click on computer and do map network server.
On the Map Network Server select the server QMG220-DA on the list and add your machine IP addess.
a new item appears on the list as QMG220-DA on 'your_machine_ip'.
right click on this one and select Connect to server. On the pop up click on connect. the light should go green within a few seconds.you should then be connected (smile)
Return on the list and right click on your server : QMG220-DA on 'your_machine_ip'. select wizard. press next and set the update rate to 100 ms. press next and then finish.
You should now be connected to your server and you should be able to see the values updating.

Connect to OPC server from labview :

open labview.Create new project.
on the project explorer right click on MyComputer then select New-> I/O server. Select OPC client
set your machine IP
set QMG220-DA as Prog ID. if a pop message similar to the left picture below, ignore it.
set the update rate to 100ms
click ok
under untitled Library right click on OPC1 the on view I/O items.
you should be able to see the fields of the opc correctly.
if you do not see that, verify that you have correctly performed all the previous steps and try rebooting your machine
If you see it , it means that you are connected and you can start programming.


I am hoping this will help.

 

 

0 Kudos
Message 45 of 95
(1,763 Views)

Stoad57,

 

My sense is that you can view the resources under OPC DA 1, but you can't use the full might of the Datalogging and Supervisory toolkit.  The reason is that to create an I/O Server - at least when I last attempted this - the communications with the OPC server on-board the QMS would have to be OPC VA version 3 .  Life would have been peachy if this was the case because the I/0 Server variables are named, have the correct data type and have error checking.  But alas this never worked for me.

 

My solution was to use Datasocket to access the OPC items. This is significantly more onerous because you need to name the variables and specify their representation.  But once that's done, it works quite well.

 

If you've had success getting the QMS to communicate as an IO Server, that would be an immense succes.  

 

If one does pursue the Datasocket approach and you try to read the Datapump make sure the you set the datasocket update rate and deadband to zero as shown in the attached.  Otherwise you will lose data.

 

Jeremy 

0 Kudos
Message 46 of 95
(1,744 Views)

Hi Jeremy,

Now that i see your reply i have doubt about the quality of my explanations on the previous post.

 

I can connect directly to the OPC DA server of the QMG 220.

 

For me the problem was to find a way to have labview finding the OPC server and connecting to it, because i could connect to the OPC server with several OPC client like matrikon quit easily but i couldn't make it with labview.

 

After a while ( long while) i finally found a solution and i could connect to it with labview and i could build my app.

 

I sugested to use the NI server explorer during installation because if you can connect to the OPC server of the QMG 220 with this client then you are almost sure that you will be able to find the OPC server with a labview OPC client.

 

Then i simply made a new project and added a new I/O server-> OPC client and that's it, i have acces to all the items of the OPC server. After that you have a OPC client variable in your project from which you can create bound variable to get the variable you need as shared variable type of object.

I agree on the point that will need to know the name of your variable to make your life easier when you are creating the bound variables.

 

I have added some picture of the FTP , Bloc diagram and project view so that you can have a look.

 

Thanks for your feedback 🙂 i also already have my application working.

I decided to post because i was going arround on the forum, i saw this post so i decided to share my solution, because it really took me a while to finally get a way to connect and actually it was thanks to a reply on a forum that i could solve my issue. Then it was very fast to build the app.

 

NB : the app was made quickly as first demo version for my coleagues. but the concept is there.

 

Antoine.

 

Message 47 of 95
(1,722 Views)

Antoine,

 

Congrats on getting this working and NICE CODE!

 

Is there anyway that you are running a different version of Quadera the has higher level OPC support?

 

I am definitely able to get data using the server explorer and I have been able to creat Shared Variables inside a project, but when I run VIs containing said shard variables, I get "no data" warnings.  All the while the several explorer is happily collecting data  

 

I am running 64 bit windows 7, which may be a headache.  But I have loaded the reg files into the regular regedit and the sysWOW64 regedit.  

 

I have Quadera 4.5.

 

I did some searching and the OPC might is not applicable if the server is OPC DA 1.  DA2 and DA3 are okay.  I thought the infinicon software was DA1 which is why I pursued the DataSocket approach.  But your success has left me intrigued.

 

Jeremy

Message 48 of 95
(1,681 Views)

@JHourigan wrote:

 

I am running 64 bit windows 7, which may be a headache.  But I have loaded the reg files into the regular regedit and the sysWOW64 regedit.  

 

I have Quadera 4.5.

 

Jeremy


Hello,

 

May I get some info about how to make Quadera function under x64 Win7? Is there any guide how to use the native software from a 64 bit OS?

Thanks!

0 Kudos
Message 49 of 95
(1,664 Views)

Quadera is running on the 32bit part of that OS, I think.   That's why you have to make sure that when you deal with the *.reg settings they need to be entered into the regedit in the sysWOW64 folder.

 

I am running LabVIEW in 32bit.

0 Kudos
Message 50 of 95
(1,657 Views)