Showing results for 
Search instead for 
Did you mean: 

labview application crash



I have a labview application which generates an Access violation (0xc0000005).


Unfortunately it appears to crash at different points in the program execution.

The program is running an ESS task and has usually run serveral temperature cycle before it crashes. Other times it runs fine.

Looking at task manager, its not running out of memory.

Its not accessing any network location. 


Everything is contained within the EXE except for some VIs which are called dynamically and these VIs are contained in a LabVIEW packed library and installed on the same drive as the application.


I was hoping the log file would provide some useful information that would point to the problem

see attached

#Date: 07 Aug 2015 15:56:41
#OSName: Microsoft Windows XP Service Pack 3
#OSVers: 5.1
#OSBuild: 2600
#AppName: ???_Test_Suite <<<<<removed filename details
#Version: 11.0.1f1 32-bit
#AppKind: AppLib
#AppModDate: 07/08/2015 14:59 GMT
#LabVIEW Base Address: 0x30000000


07/08/2015 16:56:23.134
Crash 0x0: Crash caught by NIER
File Unknown(0) : Crash: Crash caught by NIER
minidump id: 1b0d01ab-3630-4f28-957d-758aaf53e606
ExceptionCode: 0xC0000005§N
0x3072D954 - lvrt <unknown> + 0
0x3072DD08 - lvrt <unknown> + 0
0x7C37FDB4 - MSVCR71 <unknown> + 0
0x7C843E82 - kernel32 <unknown> + 0
0x00000000 - ???_Test_Suite <unknown> + 0  <<<<<removed filename details
*** Dumping Bread Crumb Stack ***
*** LabVIEW Base Address: 0x30000000 ***
#** DisposeInstrument: "C:\####\common\Instruments.lvlibp\Public\cal\9"   <<<<<removed path details
#** VILinkObjRemoveCore: "C:\####\common\Instruments.lvlibp\Public\cal\9"  <<<<<removed path details
*** End Dump ***

The reference to the lvlibp vi in the lvlog file make no sense as 'cal' wouldn't have been loaded during the ESS routines.



Are there any tools available that would make the dmp file a bit more readable?



Any sensable suggests welcome.



Ray Farmer






0 Kudos
Message 1 of 17

Hi Ray,


I did a quick search and found this KnowledgeBase paper which may contain the answer to your problem. Please let me know if that solves your problem.


There are also a number of other threads about this issue which I can help you to look through in more detail if this doesn't solve your issue.



Jake A

Applications Engineer
National Instruments UK and Ireland
0 Kudos
Message 2 of 17

Hi Jake,


I had a look at that KnowledgeBase paper and although I am not deploying the application I had a look if this sort of thing might be happening. I do have a Call Library Function Node but this calls a function in a DLL that is in Data folder of the application.

I had a look at some of the other links on the KnowledgeBase paper, but nothing sprung out as possible.


would you know what are the references MSVCR71  and kernel32 that are listing in the lvlog file?






0 Kudos
Message 3 of 17

It seems to me that the issue is coming from some sort of memory violation. It's possible that a certain process is running out of virtual memory. Have you also tried checking the cal to ensure that it works correctly? I know that it's not being called but if it is mentioned in the error report then it's definitely worth making sure it works.


Additionally, make sure all of your references are being closed properly. It could be that if the program is (or was) stopped suddenly, perhaps using the abort button instead o the stop button, that the references are still open and that is causign the issue.


What does your program look like? If you attach the code I may be able to more easily determine the cause of the error.



Jake A

Applications Engineer
National Instruments UK and Ireland
0 Kudos
Message 4 of 17

Your executable crashes, buy are you able to run this in the development environment without any issues?

If you are able to attach a few of the zip files that are created from your crash, someone at NI can look through the dumps to see if there is a common call before each crash.

Besides that, this is a pretty generic error so one of the best things to try is to remove sections of your application until you no longer see this problem. Doing this may give us more information on where to look.
Matt J | National Instruments | CLA
0 Kudos
Message 5 of 17



I have no issues running this software in the development environment.


I did have an issue with another project on this system. I had copied my files on the the C drive. Opened the project file, tried to build the execuable but had a crash of the labview, access violation error. Tried to open the VI that was list in the lvlog file and it wouldn't open.


Ended up deleting all the files and coping them on to the drive again. This time the exe built with out any problems.


I am starting to think I have a dodgy hard drive.




0 Kudos
Message 6 of 17

I was running my program in the LabVIEW environment and with the Profiler running.

I didn't see anything thing that indicated a problem area. No VI's had memory usaged that were continuely rising.


I had the windows task manager running as will and I did notice that everytime my ESS tests started running the virus scanner kicked in. This meant the CPU Usage was bouncing around the 100%. My VI that performs the ESS Tests is run dynamically, why would this start the virus scanner software?




0 Kudos
Message 7 of 17

Hi Ray, 


I've looked into this issue further but I can't see any particular reason why this might be happening without knowing more information about the code you're running. If you coudl provide me with soem screenshots or .zip files containing your code that would help me to solve your problem.


Have you tried running the EXE with the antivirus software disabled? Doing so would help to isolate the issue. I will also second Matt's suggestion that you remove portions of the code to try and isolate the problem.



Jake A

Applications Engineer
National Instruments UK and Ireland
0 Kudos
Message 8 of 17

How are you doing with this issue, Ray? Have you managed to find the source of the problem or any kind of workaround?




Jake A

Applications Engineer
National Instruments UK and Ireland
0 Kudos
Message 9 of 17

Good morning Jake,


I am also having similar problems with Labview and MAX as well. Both started crashing since 5 days. I was working on four devices: one USB RAW and three of them serial devices. I am doing experiments and collecting data from them when suddenly one USB RAW device was not reading so I tried troubleshooting for this device whereas other devices seemed working fine. I have spent good amount of time going through the forums but no success at all. Now LV works fine if the COM port # is already there but if it is not there and I try to use drop down on VISA resource name, LV crashes. Please help.



0 Kudos
Message 10 of 17