LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

installer problem

Solved!
Go to solution

Hi, I have LabVIEW 8.6 and am trying to create an Installer. I have existing code (someone elses) that I have copied into a project. I have selected all my source files from the project and have added LV 8.6 run time engine. The Installer builds OK to my destination file and when I copy this to my target PC and run it, it installs ok. However, when I try to run my app, windows doesn't recognise this as a LabVIEW file and will not run it????

 

Any suggestions? I've never built an installer before!!

 

Thanks,

 

Steve s

0 Kudos
Message 1 of 4
(782 Views)
Solution
Accepted by topic author Steve_S1

Hi Steve,

 

from your description it seems to me as if your installer will install the VIs on the target machine. If you want to run the application on a PC without LabVIEW installed you need to create an executable first. In the project file, create a build specification for an application (exe) and build this. Then create an installer with the compiled application and LV Run-time engine.

 

Hope this helps,

Daniel

 

Message 2 of 4
(772 Views)

Hey Steve,

 

What Dan said is right on track, it sounds like you are trying to use VIs with a Run Time Engine. The RTE will only allow for an exe to be run, nothing in the development environment. Since a VI is basically source code, you won't be able to use that.

 

The only extra thing I would like to add is that you reall don't need to BUILD the exe. You can just set up the specs for it, click OK, and you will now see that as an option for your installer. 

 

 

Chris Van Horn
Applications Engineer
Message 3 of 4
(768 Views)

Thanks Guys, I knew I had to be doing something fundementaly wrong! Hey ho. All done now thanks

 

Steve

0 Kudos
Message 4 of 4
(741 Views)