LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

how to connect the two terminals of the different types?

Solved!
Go to solution
Highlighted

VI for plotting  measured power and time.VI for plotting measured power and time.The type of the source is double [64-bit real (~15 digit precision)]. The type of the sink is 1D array of the double [64-bit real  (~15 digit precision)].

 

How to connect these two different terminals.

 

0 Kudos
Message 1 of 8
(214 Views)
Highlighted

Your source is a double.  The sink (the input of the node) is asking for an array of double.

 

So how do you turn a scalar into an array?

 

Use Build Array!

 

Now those two things will connect.  Whether that does what you truly want your VI to do is a completely different question.

0 Kudos
Message 2 of 8
(176 Views)
Highlighted

Actually I want to plot the measured power as a function of time. I use time elapsed vi to measure time and power drivers to measure power. Then I use a waveform chart to show these parameters in the graph. 

0 Kudos
Message 3 of 8
(167 Views)
Highlighted

Hi prabesh,

 


@prabesh99 wrote:

I use time elapsed vi to measure time and power drivers to measure power. Then I use a waveform chart to show these parameters in the graph. 


Using ElapsedTime to set the dt of a waveform is nonsense…

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 4 of 8
(161 Views)
Highlighted

Hi 

Gerd,

What should I do then? shall I use get time or count time vi?  Actually, the plot is not showing as the time. I am sorry for asking such an easy question.  

Thank you

0 Kudos
Message 5 of 8
(157 Views)
Highlighted

Hi prabesh,

 


@prabesh99 wrote:

What should I do then? shall I use get time or count time vi?  Actually, the plot is not showing as the time. I am sorry for asking such an easy question.  


Do you even know what the purpose of dt is in a waveform? Do you know why it is silly to store the elapsed time into the dt value? Do you know the purpose of the t0 value in a waveform?

 

You should explain your task with more details!

When DAQ is done at regular intervals then you should create a waveform where dt is set to that interval.

When DAQ is done on non-regular intervals you should use a XYGraph instead…

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 6 of 8
(151 Views)
Highlighted
Solution
Accepted by topic author prabesh99

Dear Gerd

Hi,

Thank you for your reply.

I want to measure the time interval. yes., I know the purpose of dt and t0 value in the waveform. 

I used bundle vi also in order to connect time vi and power vi with the waveform chart. But I got an error. The error is about the data type.

 

Thank you

 

0 Kudos
Message 7 of 8
(146 Views)
Highlighted

Hi prabesh,

 

please don't send PMs to ask LabVIEW-related questions! Such questions belong into the LabVIEW board, where you already started a thread!

 


@prabesh99 wrote:

I used bundle vi also in order to connect time vi and power vi with the waveform chart. But I got an error. The error is about the data type.


This has already been answered in message #2!

 

When you need specific help for your code then you should attach that code to your message. We cannot debug images in LabVIEW and we will not provide the best help when we only see small portions of the code in your images!

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 8 of 8
(139 Views)