LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

how can I disable the internet ( DNS server ) contact for an executable generated in LV?

I am making some tests.

I build a simple project with 1 vi, that at timeout event (every 200ms) just do the sum of 2 numeric controls, and put the sum into an indicator. It exits on panel.close event.

I build it (created the exe, not the installer), and I just copied the build folder into a PC (aka "Test PC" ) that does not have McAfee. It has ZoneAlarm , last version free available.

I get the same response, and now with the more detailed infos of ZoneAlarm, I can say that the "Ni service locator" is trying to access the internet 🙂 That port is the one of NI service locator.

"Test PC" had all labview development versions installed (from 6.1 on), now I am uninstalling all, and want to leave only the runtime 8.5.1. I will check if I get the same zone alarm alert.

 

So how can I disable the NI service locator from popping up the firewall??

 

 

Message Edited by Slyfer on 03-02-2009 01:19 PM
0 Kudos
Message 21 of 37
(1,840 Views)

Slyfer,

 

The alert that you postedfrom ZoneAlarm says that the destination is the service locator- 127.0.0.1:3580.

 

The only thing that comes to mind that could be trying to register a service with the service locator is if you have the option enabled to make the built application debuggable. This will register the port that a remote LabVIEW can connect to to debug the running application.

 

Can you check if you have the "Enable debugging" option checked in the Advanced page in your build specification.

 

By the way- as this communication is to the localhost it is not trying to connect to the internet and I would argue that it is incorrect for your firewall to report it as such.

 

Thanks,

 

Nathan

0 Kudos
Message 22 of 37
(1,820 Views)

In my Test PC, with winXP pro updated, I installed everything about NI. I only reinstalled LV RT 8.5.1

In the building of my test application (the simple sum of two indicators) I checked that "allow debug" is disabled (advanced tab of building properties). I recompile and copy the exe on the Test PC.

Again Zonealarm intercept the NI service locator.

I left Zonealarm with default options, I agree that a request on localhost (127.0.0.1) is not properly a "trying to access the internet".

It just sounds funny though that doing and building the same program with , let's say, visual studio, doesn't harm firewalls...

This behaviour is annoying expecially on my version of mcafee, because it puts more than 1 entry for every modification (in the "allow" list, I found multiple entries of the "test.exe" program), while with zonealarm just says "the program is modified, allow access?" --> yes and checks remember

 

Message Edited by Slyfer on 03-03-2009 08:46 AM
0 Kudos
Message 23 of 37
(1,796 Views)
Sorry, I don't have a virgin computer available so I cannot test this myself, but when you installed the runtime engine, did you select any of the optional components? If so which ones?
Message 24 of 37
(1,785 Views)

I built an executable and installer in 8.6 (I don't have 8.5.1 installed right now) and it didn't register any service with the service locator. I watched all the packets in wireshark and there were none to or from port 3580.

 

After launching your executable, and clicking allow to let the firewall let the traffic through, you can see if it registered a service (rather than querying the service locator) by navigating in a browser to the URL http://localhost:3580/dumpinfo? This will show you everything that has been registered with the service locator.

 

Can you attach your simple executable so I can try it?

 

Thanks,

 

Nathan

Message 25 of 37
(1,768 Views)

To tell teh truth I don't remember which component I installed. I can't remember if I installed all or just something.

I'm going to investigate better.

Attaching materials

0 Kudos
Message 26 of 37
(1,753 Views)

Slyfer,

 

Thanks, I've done some tests and I figured out why this is happening. I have not yet decided if there is a workaround.

 

When LabVIEW starts it contacts the service locator to removes all services for itself. This request is triggering the firewall.This is done in case there were services that were not unregistered the last time LabVIEW executed- for example from VIs that didn't clean up after themselves.

 

Incidentally this happens in 8.6 as well- the reason I hadn't seen it before is because I had the alerts turned off for my Windows firewall.

 

I'll get back to you if I can find a workaround but I suspect, as this behavior is in the LabVIEW exe, it may not be possible to turn it off until I fix it in a future release.

 

Nathan

Message 27 of 37
(1,745 Views)

If I remember well, I also tried to disable all the server options when building the exe.

Both in the building properties and in the Labview general options.

I was wondering if there was some "switch" that disables this behaviour.

TO me this behaviour is annoying because my firewall is "centralized" by net-admin, and I don't have full control. So every time I make some modifications to Vis, after building again, I get every time this pop up firewall message. And even if my pc is new, it's slow to update, I mean Mcafee is slow when I click its "allow" button, until it goes away

0 Kudos
Message 28 of 37
(1,714 Views)

Unfortunately there isn't a switch to disable it. I agree that this behavior is annoying. I will have this bug fixed in the next major release of LabVIEW.

 

Thanks,

Nathan

0 Kudos
Message 29 of 37
(1,687 Views)

We cannot disable NI service locator even if we don't use it.

I have just installed LV 8.6.1

I will repeat some tests, otherways I'll wait next LV release

0 Kudos
Message 30 of 37
(1,660 Views)