Showing results for 
Search instead for 
Did you mean: 

google map error in web browser



I am trying to embed google maps into the my LabVIEW GUI using a web browser. Initially it used to work fine but today it started showing this error message. Please let me know how I can fix this. I just want to display google maps and modify the source and destination based on the entry into the text bx by the user.


Thank you.

0 Kudos
Message 1 of 7

Hello Bharat, 


I just want to clarify a few things with you about when this error happens:

1) What version of LabVIEW are you using? 

2) What changed between when it was working and when it wasn't?

3) What are you doing when this error appears? Does it happen when you drop a node, or when you click the run button?

4) Is the error consistent? Does it happen every time you run the VI?


Knowing this will help us narrow down what the problem might be!



0 Kudos
Message 2 of 7

Hello Siana


1) I am running LabVIEW 2012.

2) Nothing changed between the last time it was working and when it wasnt. It was working on Friday and then on Monday morning it started showing this script error

3) I am pushing a button that triggers an event and executes the invoke node of the web browser and modifies the URL.

4) The error is consistent. It happens every time I try to run the program. The program runs but the web browser doesnt function like it should.


Please let me know how I can fix it. The problem I think lies in the browser or the way the invoke node of the browser is executed but what I dont understand is that it worked perfectly fine last week.


Thanks a lot for helping me out with this.





0 Kudos
Message 3 of 7

Hello Bharat,


This error looks like it was generated from Internet Explorer, not LabVIEW. The most likely cause for this is that over the weekend Internet Explorer updated. You can check this by going to Control Panel > Programs and Features > View Installed Updates, and then sorting by Installed On date to see what has been recently updated. If Internet Explorer is on this list, you can revert to the previous version by clicking the update and choosing Uninstall. Another possible cause is that Google updated so that the URL you provided is no longer valid, in which case you would have to change the hard-coded URL in your VI to the new site location.


If neither of these steps work for you, we could learn a bit more if you were to wire a Simple Error Handler VI to the output of your invoke nodes at the start/stop journey events. I attached a picture of what that would look like. If you do this, please reply with whatever errors LabVIEW shows when you run the code.


Have a good day,

0 Kudos
Message 4 of 7

Hello Siana


I did check the list of updates and it looks like Internet Explorer was not updated this past weekend. I also added a simple error handler VI to make sure that there was no problem with the VI. It looks like Google has updated the link and so I have to change the code to match the new link.


Thank you so much for assisting me with this and helping me solve my problem.





0 Kudos
Message 5 of 7

Is it possible to use another browser i.e not Internet Explorer? This is because I tried using the entire link that I copied from google maps and it still showed the same error. And when I checked the updates that were installed, there were none since mid August for IE

0 Kudos
Message 6 of 7

Hello Bharat,


I actually found a link to another forum post which talks about using Mozilla Firefox in the ActiveX Container in LabVIEW. That forum is here:


Based on the discussion, it looks like there is a downloadable ActiveX Control for the browser which can then be used in your VI in place of the Microsoft Web Browser. Hope this helps!


Have a good day,

0 Kudos
Message 7 of 7