LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

front panel state of VI in subpanel

Up until last week this code has been working flawlessly ... I have been dynamically loading VIs in and out of a subpanel.  While the VI is in the subpanel, the user has been interacting with it using custom events within that VI.  In the process of trying to create a simpler way of keeping track of the dynamically loaded VIs from the main VI, the whole process of interacting with the dynamically loaded VIs in the subpanel has stopped working.  The VIs load into the subpanel just fine, but their front panel state remains at "standard" instead of changing to "hidden".  what could be preventing this?  I've included a snippet from the main VI that shows how the VIs are dynamically loaded.

0 Kudos
Message 1 of 4
(1,883 Views)

Hi.

 

Why do you open up your front panel first? remove that Smiley Wink

 

Make sure the VI is running in memory. Load you VI into the Sub panel. Front Panel Window:State should show closed by default before loading into subpanel (atleast when I clone multiple VIT's in memory and show them in a subpanel) if not configured otherwise. After loading teh state should be standard.

0 Kudos
Message 2 of 4
(1,865 Views)

Just to add :Smiley Very Happy

When replacing the the VI loaded in the subpanel with another VI, the previous VI window state goes automatically back to closed 🙂

0 Kudos
Message 3 of 4
(1,856 Views)

just an fast example. Instead of creating some test VI's I used a template

sspanel.png

0 Kudos
Message 4 of 4
(1,840 Views)