LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

fpgawon't compile

Bringing up FPGA on a new system

Installed LV/ and FPGA 2010. could not run latter part of of FPGA install perhaps because only have access to Device drivers 2011?

NI LabVIEW 2010 FPGA Module installed. NI-RIO not installed. I will be programming PXI R7831 and R7851 devices.

(Will try to get 2010 disk from the our "license dictator" who controls them tomorrow)

Will access to the 2010 disk correct the problem or do I need to fix something else?

 

Here is the error i get when I try to compile.

 

The compilation tools are not installed on this machine. Run your LabVIEW FPGA installer again and select the compilation tools, or try connecting to a compile server on another machine.

Details

Error -123011 occurred at niFpgaCompileFarm_OpenSession.vi

Possible reason(s):

NI-Farm: Farm server is not responding. Be sure the specified hostname is correct, the server is running and configured to accept remote requests.

 

Complete call chain:

niFpgaCompileFarm_OpenSession.vi

niFpgaCompileWorker_OpenSession.vi

niFpgaCompile_Worker.vi:1

Judd
0 Kudos
Message 1 of 4
(1,654 Views)

Hey Juddster,

 

Simply installing the 2010 version of the device drivers might solve your issue but I would like to lead you to this site that details the software needed to support our RIO hardware:

 

ftp://ftp.ni.com/pub/devzone/tut/crio_software_versions.htm

 

 

For your PXI 7831R you would need LabVIEW version 7.1 or newer, LabVIEW FPGA module 1.1 or newer, LabVIEW Real-Time module 7.1 or newer, and NI-RIO drivers 1.1 or newer.

 

For the PXI 7851R you would need LabVIEW version 8.6 or newer, LabVIEW FPGA module 8.6 or newer, LabVIEW Real-Time module 8.6 or newer, and NI-RIO drivers 3.1.0 or newer.

 

Hope This Helps,

 

Doug B

Applications Engineer
National Instruments
0 Kudos
Message 2 of 4
(1,642 Views)

For both the 7831 and the 7851 you will only need the LabVIEW Real-Time module if you are using a RT controller in the PXI Chassis. If you are using a windows controller or MXI system you will not need the Real-Time module.

 

Hope This Helps,

 

Doug B

Applications Engineer
National Instruments
0 Kudos
Message 3 of 4
(1,637 Views)

You will need NI-RIO installed to get target support for the FPGA devices in the project.  You will also need to install the Xilinx compilation tools in addition to the FPGA Module.  For the 7831R, you will need the Xilinx compilation tools for Virtex-II devices and for the 7851R, you will need the Xilinx compilation tools for devices other than Virtex-II.  These can be found on the installation disc used to install the FPGA Module, but are separate installations.

Donovan
Message 4 of 4
(1,633 Views)