Showing results for 
Search instead for 
Did you mean: 

error with -63193 peer to per communication ith LabVIEW FPGA


Hi, I’d like to ask for some help with peer to peer streaming. I have to stream data between two FPGA cards and whatever I tried, I always get error (-63193) when I try to invoke the P2P writer or reader in my host VI. There is no error after the openinig the FPGA vi references.


The configuration is:

PXIE 1082 chassis

PXIE 8821 controller that runs WIN10

Two 7975R FPGA modules. (From this aspect, it is not important, but both has a 5782 module)


The host VI runs on an external PC. Other functions such as signal generation, data acquisition, triggering…work perfect.


LabVIEW version: 2018 with latest drivers.


I’ve prepared and attached a very simple dummy project.

Can anyone help me to make P2P streaming work?

Certified LabVIEW Developer, Certified LabVIEW Embedded Systems Developer
0 Kudos
Message 1 of 4

Have you tried the shipping example:

\examples\FlexRIO\Peer To Peer\Peer to Peer - Basic

Certified LabVIEW Architect, Certified Professional Instructor, LabVIEW FPGA expert
ALE Consultants
LabVIEW Programming (make LV more popular, read this)
0 Kudos
Message 2 of 4

Thanks for the advice. I've studied that example, and noticed that my code was basically the same. (Except of some synchronization.) And with that I had the same error.


But, there was one significant difference: In the sample code, the host is the PXI controller, and the host VI runs on that. In my code, the host was a remote PC, and so, the host vi also was a remote one (something like connecting the FPGA of a cRIO directly from a PC neglecting the RT CPU.)


So my final idea was installing LabVIEW on the PXI controller and this way, moving the host vi there too. And it worked Smiley Happy


So, the lesson that was learnt: in PXIe systems the peer to peer communication does not work if the host vi is on a remote PC. I'll make the code look a bit nicer and upload it soon.

Certified LabVIEW Developer, Certified LabVIEW Embedded Systems Developer
Message 3 of 4

Hi David,


Thanks for sharing the information!


Could you please help post your code on the page? I also met with -63193 error in PXI RT host. Do you know P2P is supported on RT OS?



0 Kudos
Message 4 of 4