Showing results for 
Search instead for 
Did you mean: 

error loading niimaqdx.dll


Hi all,


Labview 8.6 Professional Version. Attempted to load a vi written on another machine when I received the above error (screengrab attached). LabVIEW then closes. There was no niimaqdx.dll in the c:\windows\system32 folder, so I copied it over but still not resolved.  The vi works fine on the other machine (niimaqdx.dll in system32 folder).


Difference between machines: malfunctioning machine is Windows 7 (but everything else works!), functioning PC is XP. I know Windows 7 is not supported. The LabVIEW installer doesn't work so each individual component had to be manually installed. Unless I missed a component...


Any help advice gratefully appreciated. 




0 Kudos
Message 1 of 6

Forgot to mention that the NI-Imaqdx palete is available in Vision functions however when selecting nay of the niimaqdx functions the above error occurs. 

0 Kudos
Message 2 of 6

Hi Leeser,


One question I have for you is, are the Operating Systems on each of the PC's running 32 bit operating systems. If the problematic machine was running 64 bit Windows, this could be causing problems, as you would imagine. I assume that the application you have is using the IMAQdx driver, have you tried re-installing the driver or updating to the latest version?


Failing this it sounds very much like a compatibility issue between Windows 7 and LabVIEW 8.6 which, as you rightly alluded to is not supported by National Instruments. As a result, my only other recommendation, would be to upgrade to LabVIEW 2009 which is supported in Windows 7.


I hope this helps.


Best Regards,


Christian Hartshorne



0 Kudos
Message 3 of 6

Hi Christian,


One PC is 32bit XP the other problematic one is 64bit WIndows 7 but running only as a 32bit  (if that makes sense?). I don't think this is the issue however as a colleague is running the same spec labview on the same spec Windows 7 machine as I am and he has no issues whatsoever.


I have reinstalled the driver, removed labview completely, reinstalled and still no joy.


I am reluctant to upgrade to LabVIEW 2009. I had previously done so on the XP machine but decided to revert to 8.6 as there were too many broken wires etc on upgrade. Also when creating an exe for distribution the application builder was looking for cds/dvds from every previous upgrade. I eventually removed everything and reinstalled 8.6 as the only version on any pc in the office/lab.





0 Kudos
Message 4 of 6

Hey Leeser,


I know this is a few years too late, but did you end up fixing the error ever? If so, a little guidance would be appreciated.The error pops up every time a VI with ImaqDX functions is employed. I can access the palette and use the functions but it gives an error on opening. Please advice.





Message 5 of 6

I have the same problem.

Att. Sebastián F.

0 Kudos
Message 6 of 6