LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

error code at property node(arg1) in VISA configure serial port

Sir/Madam,
         I am having a problem when I build a ".exe" file using application builder.I built an executable file for serial communication with labview.When I run it on other pc where labview runtime engine is installed the VISA resource name cannot be altered while rest of the parameters like buad rate,parity etc.can be changed with scroll arrow.The VISA resource name by default shows name "ASRL2::INSTRU" when I run my executable;even after i have saved that VI with settings of COM1.

        I am getting an error in the following form-
       Error-1073807343 occured at property node (arg1) in VISA configure serial port(instru).vi>
       pOssible reasons:
       VISA:(hex 0XBFFF0011)insuficient location information or the device or resource is not present in the system.

 

What is arg1??

 

I have a second query regarding labview 7.1 which doesn't have DLL and shared library option in Tools.Why it is not showing so?

 

 

Best regards.

0 Kudos
Message 1 of 19
(2,541 Views)
Arg1 is the VISA resource name. did you import the hardware configuration?
0 Kudos
Message 2 of 19
(2,537 Views)

what is meant by importing a hardware??....as far as i know i have not imported any hardware.....when i run my.exe on my by scrolling arrow i can change my visa resource settings from ASRL2::INSTR  to COM1...But when the same i try to do on other pc...the scroll options are disabled only for visa resource name..rest of the serial port settings can b altered with the help of scroll...if arg1 is visa y i cant c it in visa library??

 

best regards. 

0 Kudos
Message 3 of 19
(2,533 Views)
Ahhh . Does target PC even have VISA? When you create your exe its a good idea to create an installer for the app. this allows you to create additional installers for required software and drivers you can even import hw config (MAX settings) to set-up the target machine painlessly .
0 Kudos
Message 4 of 19
(2,525 Views)

ohh....Then what is the use of ".exe" file if u r saying to have a VISA on target PC??...  as supposed.exe file should get run properly anyewhere even if there are no supporting hardware or software..i have installed labview runtime engine on other pc..so that would be sufficient as far as i know???....All the settings i have done correctly in MAX.But still i m getting th problem of ASRL2::INSTR even if there is no such option that i have selected.

 

 

 

 

best regards. 

0 Kudos
Message 5 of 19
(2,515 Views)
Your concept of an exe is wrong. You MUST Install all hardware drivers and that includes VISA.
0 Kudos
Message 6 of 19
(2,511 Views)

ok..thanks ..so how should i install that h/w drivers on other pc??.. would NI device drivers CD do get installed on other pc if there is no labview installed there??.....or otherwise will i have to load it from internet?..when i install labview run time engine on other pc doesn't it get installed with all the h/w drivers?

 

my 2nd query is-

we here at National Chemical Laboratoty,Pune have both labview 7.0 and labview 7.1 license copies.but there is no option "build application or shared libraries" in Tools menu.i have been trying installing the CD again and again to get this option but nothing happened..what could be the possible reason?

 

 

best regards.

0 Kudos
Message 7 of 19
(2,507 Views)

sorry .... correction in above msg...there is no option in labview 7.1 version for application builder or shared library..labview 7.0 does show this option.  

0 Kudos
Message 8 of 19
(2,503 Views)
Check to see what type of license you have. Only the professional version comes with the app builder. It can also be a separate purchase as an add on.
0 Kudos
Message 9 of 19
(2,495 Views)

It is mentioned on the licensed copy that we have with us for labview 7.1 as---LabVIEW 7 Express Full Development System..

 

and  for labview 7.0 it is---LabVIEW 7 Express Professional Development System.

 

 

How should I load hardware drivers that include VISA on a PC where labview is not installed??

 

 

Thanks and Regards.

0 Kudos
Message 10 of 19
(2,492 Views)