Showing results for 
Search instead for 
Did you mean: 

error 7, report generation toolkits do not work after building.

Go to solution

Hallo guys:

one problem. help!

I tried to build my programs with application builder, unluckly builded exe application does no work well as before, i checked some similar post from this forum, and added that NIReprot.llb in my project and rebuild, the problem still takes place, my program append some text, tables, and charts into a word template with that Report Generation Toolkits, but it always gives out error 7 and 'NI_Word.lvclass:new report -> NI_report.lvclass:New -> Creat New ->...'error information.

is there anyone can give me some clues about this annoying problem.

thanks a lot!!!


0 Kudos
Message 1 of 13
Start here
Message 2 of 13
thanks for the reply, i tried this already, add that NIReprot.llb to my program, but does not work. 
0 Kudos
Message 3 of 13
So you're using LV 8.6 and Report Gen Toolkit 1.1.3?  (Use MAX to verify installed version of toolkit.)  You added the directory to your project and included the .llb as a dynamic vi in Application Builder?
0 Kudos
Message 4 of 13
yes, i attached all this library to my project, but does not work. i can not figure out the problem, any idea?
0 Kudos
Message 5 of 13



Suggest you start a new project and create a simple vi that uses report gen functions the same way you are trying to use them in your app.  Try compiling that into an .exe and see what happens.

0 Kudos
Message 6 of 13

When you say "attached all this library to my project", it is not clear whether you answered the question about including the dynamic VIs in your build specifications. See attached image. You will need to select the files in your project and set them to Always Included. Have you done this?

0 Kudos
Message 7 of 13

yes, i did this also, added them in my project and rebuild, but it does not help.                                                               Right now i created a test project with very simple report generation function, it works !!!, but i am still do not know why, i will rerange my project, i hope the problem can be solved. 

and thanks guys for your advices.
0 Kudos
Message 8 of 13
Accepted by topic author zybear



Suggest you take the simple test vi and begin adding all the functionality of your original application.  Build it up in stages and test at each stage.  Hopefully this will help you identify the problem.

0 Kudos
Message 9 of 13

I am having a similiar problem and tried to do what you suggested.  The .exe program runs in the computer where LabView 2010 is installed but not in another computer that has the LabView 2010 runtime engine.  It is still looking for the path -->\1abvi3w\vi.lib\utility\niReport.llb\Standard Report\NI Standard Report.lvclass and can't find the file.

0 Kudos
Message 10 of 13