LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

error -2555 with tdms

Solved!
Go to solution
Pretty wierd and can you check for the readonly condition
0 Kudos
Message 11 of 15
(593 Views)

The file is not read only but marked as "Windows can compress it". (I don't know how this option is called in windows-english)

 

But what I just found:

 

When I completly rewrite the VI (not copy and paste) it works as before!

 

Well the VIs were written when TDM first was introduced and since then a few LV Versions passed by.

And with each version I had to recognize some changes in the TDM(then TDMS) System and VIs.

Maybe the error can be found there.

E.g. I found these small Error -2532 deleting VIs in my code (I did not put them there!)

 2532.png

 

 

And also I had an issue with the LV Service when some other VIs of the same project were impossible to open with LV2009. (It was only solved with the SP1)

 

 

All in all I think I have to rewrite the VIs to solve this.......

0 Kudos
Message 12 of 15
(589 Views)

I have just extracted the essence of the error.

 

Could someone please try to run this LV2009SP1 VI ?

 

When I run it an error pops up that should not be there.

 

Can anyone confirm this? 

Message 13 of 15
(563 Views)
Solution
Accepted by topic author CtheR

Hi CtheR,

 

I can reproduce the error popup in LabVIEW 2009 SP1.

It's a bug of the code generation of the Read Data Express VI, resulting a subVI having an unwired error out.

CAR# 211619. Thanks for reporting the issue!

 

Mavis

Message 14 of 15
(539 Views)

Just came across the same code snipped from 6 years back. Just want to say that the code now works with LV2015. So the car# got processed. Late kudo given.

0 Kudos
Message 15 of 15
(182 Views)