LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

empty functions palatte quick drop issues

Hi all,

 

I am having some issues ever since upgrading to 2013sp1 for Labview development.  I just updated the system in question and now the function palatte is empty and if I attempt to access the quick drop menu while in the block diagram view labview closes with no messages or errors.  I have already attempted to un-install labview 2013 / reboot combintaions.  I have not un-installed all NI products though just Labview 2013.

 

I can still access the quick drop menu while on the front panel with no issues.  Any pre-existing code that exists in the block diagram still works and all the VIs still work for the project I just cant add new items from an emtpy functions palette although I can copy and paste pre-existing code just fine.

 

Any feedback or suggestions would be great.

 

-Andrew

0 Kudos
Message 1 of 4
(638 Views)

Hey akonecki,

 

It's possible the directory for the functions palette is somehow incorrectly configured, especially if you can still execute code without a problem. Take a look at this KB, which talks about modifying the menus directory location to fix this empty controls/functions palette issue.

 

Regards,

 

Ryan

Ryan P.
National Instruments | Systems Engineer | CLA
0 Kudos
Message 2 of 4
(606 Views)

From any Block Diagram menu View>>Functions Palette  will bring up your empty palette hit Customize>>Change visible Palettes...

Capture.PNG

You'll get this

Capture.PNG

Chose restore defaults or select all  and click ok

Be careful you don't hit deselect all by mistake (again) or you'll get an empty function paletteSmiley Wink

0 Kudos
Message 3 of 4
(596 Views)

Thanks all.  So the issue has been resolved but there are a couple of extra issues I ran into first.  Jeff,  what you suggested was the first thing I tried.  The issue ended up being that all my available Palette Categories was empty thus giving me no slection. 

 

In order to get my Available Palette Categories to be populated I reset the default path of where the VIs where expecting to be.  Once I did that Labview complained about a License issue and I discovered that the system was expecting a remote license server that was no longer available.  I removed the remote servers reset the system and my palettes were there again.

 

I think the root cause that generated the issue was due to the fact the another member of my team may have had Labview open during the updates, resulting in the miss configuration of the palette directory and corrupting which license was expected to be used.

 

Thanks for the help,

 

Andrew

0 Kudos
Message 4 of 4
(566 Views)