LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

.dll not loaded even after path is provided

Solved!
Go to solution

I am using a .dll from .NET with my LabView 8.6 application. It works, until I try to build it with Application Builder. It says this:

image.png
So I point LabView to it, and then:
image.png

How is this possible, that when I point to the directory of .dll, it still does not find it? I tried putting it in different directories, also the support directory and data directory, but it all ends this way. How do I solve this?

The weird thing is there are like 5 dlls, and this is the only one it asks it for.

0 Kudos
Message 1 of 5
(705 Views)

Are you using Windows 10? LabVIEW 8.6 is not even listed as compatible with Windows 7...

 

0 Kudos
Message 2 of 5
(682 Views)

Compared to the development environment, the runtime environment (EXE) doesn't recognize the folders <vi.lib>, <user.lib> and <instr.lib>.

Your screenshots indicate that the assembly is located in the instr.lib. You have to include the dll in your build script and copy it to a dedicated folder.

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
0 Kudos
Message 3 of 5
(675 Views)

I am sorry, but I do not understand what you mean by "build script" and which folder are you referring to. Could you elaborate? 

0 Kudos
Message 4 of 5
(664 Views)
Solution
Accepted by topic author Atizss

So I finally found the solution for it: My .dll was built using .NET 4.0 framework, but according to https://knowledge.ni.com/KnowledgeArticleDetails?id=kA00Z0000019L3hSAE&l=nl-NL, LabView defaults to 3.5. So I followed the instructions there and fixed it. However, I must note that it took too much time finding this information.

0 Kudos
Message 5 of 5
(659 Views)