LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

dependency path

Solved!
Go to solution
Highlighted

Hi everyone, I found a program in this community and when opening it, I always have these warnings in the image below. What could be this error? I even changed the path of the project in the same folder of the driver but it's not working.

 

 

 
 

 

0 Kudos
Message 1 of 8
(233 Views)
Highlighted

The problem is that whoever originally wrote all of your VI's and subVI's used the library they had saved at their desktop rather than the instr.lib folder under LabVIEW.

So the paths were all saved pointing to that location.

 

You opened it in LabVIEW, it couldn't find it at that \Users\WSI\Desktop directory path, but did find it under LabVIEW\instr.lib.  It is just warning you it updated the links to the new location.

 

I don't know what you mean exactly by " I even changed the path of the project in the same folder of the driver but it's not working".

 

The solution is to resave all your VI's so that they are pointing to the correct instr.lib location.  And to go to the original PC and move the library out of User WSI Desktop over to the instr.lib directory so that this doesn't happen again.

0 Kudos
Message 2 of 8
(224 Views)
Highlighted

Thank you for your response, but It's strange, I did the exact thing as you said and I still have the same problem I moved the project and the drivers in the same library and in the expected path it shows like I have a double folder Agilent but I only have one.

I don't understand.

ma994_0-1594582499098.png

 

 

0 Kudos
Message 3 of 8
(212 Views)
Highlighted

You must have made some difference when moving them.

 

Try saving all the VI's again.   Since it is in a library, you will likely have to make sure the library file itself gets saved.

0 Kudos
Message 4 of 8
(209 Views)
Highlighted

Thank you for your help. I have another question do you have any idea why it shows all these files are affected. These are the drivers files I did only the installation for lcr meter.

ma994_0-1594584656214.png

 

 

0 Kudos
Message 5 of 8
(202 Views)
Highlighted

Because they are all the ones found in a different directory than they were originally.

0 Kudos
Message 6 of 8
(178 Views)
Highlighted

But I didn't touch their directory..I only installed the drivers for the instruments and it shows like they are affected when I open one of them.

 

0 Kudos
Message 7 of 8
(128 Views)
Highlighted
Solution
Accepted by topic author ma994

@ma994 wrote:

But I didn't touch their directory..I only installed the drivers for the instruments and it shows like they are affected when I open one of them.


That is the fault of the developer.  Just save your VIs and be done with it.


GCentral
There are only two ways to tell somebody thanks: Kudos and Marked Solutions
Unofficial Forum Rules and Guidelines
0 Kudos
Message 8 of 8
(123 Views)