LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

comunication with AT89S51 microcontroler through COM port?

Highlighted

Well, now that you have error handling enabled, you are getting a framing error and that indicates a mismatch between the com settings of the pc and the micro.

 

And you still did not change to hex display. If you don't want to do that, then explain why. Otherwise maybe you should try to figure out what is wrong by yourself. 

 

Hyperterminal is a standard windows program (at least before Vista). It has it's own help program.

0 Kudos
Message 11 of 17
(894 Views)
Highlighted

Thanks, Dennis Knutson.

You want to say I have to change "hex display" similar this picture. I want sent a ASCII character and display it on read buffer on front panel if change hex display I afraid don't display ASCII character on read buffer .  Sorry for I depend to you more. But I did my idea not complete so I haven't any idea difference to do it.

0 Kudos
Message 12 of 17
(884 Views)
Highlighted

Finally.

 

Everyone knows you want to read and write ASCII but it's obvious that is not working. The hex display shows that you are not close to reading an 'h' back. An h is the same thing as x68. I was hoping the hex display would show a simple bit swap. That's not true. If you are still getting the framing error, then you have the micro programmed to something other than the 8 data, 1 stop, no parity that you think you do. There is nothing wrong in the LabVIEW code and nothing you can do in the LabVIEW code except make it match the com parameters that the micro is actually using.

0 Kudos
Message 13 of 17
(876 Views)
Highlighted

It is not unusual that then starting a RS232 session from "cold boot". That the two UARTS need to receive one or two bytes to get synchronized. But after the communication should be stable. So I suggest you modify the .....\examples\instr\smplserl.llb\Basic Serial Write and Read.vi as shown in my picture. Save it using "save as" so other may use the example later. Now you can repeat your test. I hope you will get stable results after the two devices are synchronized

 



Besides which, my opinion is that Express VIs Carthage must be destroyed deleted
(Sorry no Labview "brag list" so far)
0 Kudos
Message 14 of 17
(851 Views)
Highlighted

Hi, Coq rouge, thanks you.

I did everything follow  the suggest of you and everybody. But the first error of my project haven't anythings change. Now maybe I have to make a difference hardware. I'll say to you when have any avolve. If you have any idea please sent to me. see you late.

 

0 Kudos
Message 15 of 17
(829 Views)
Highlighted
Are you using some sort of development board, with a RS232 port. Because the serial port do not acept TTL type signals. You have to insert a RS232 level translator like MAX232 between the CPU and the serial port.


Besides which, my opinion is that Express VIs Carthage must be destroyed deleted
(Sorry no Labview "brag list" so far)
0 Kudos
Message 16 of 17
(825 Views)
Highlighted

Hi, everyone!

I have solved problem comunication with AT89S51 microcontroler through COM port. I can sent a character string to LCD 16x2 and if i want to sent a diffrence string, I have to clear before string on LCD. But my problem is it can't display the character on labview, the string also display but it only appeare at a little time.

Would you please see and say to me a idea to solve this problem. thanks all. Funny

this my program labview and micro. 

0 Kudos
Message 17 of 17
(733 Views)