Showing results for 
Search instead for 
Did you mean: 

communication error -123053, compile server

Go to solution

Hi @ all,

I have a problem by compiling VI's with on my maschine / FPGA and I don't know the reason why.

For testing I took two examples from LabView but all the time I got the same error.

The message look's like:


A communication error occurred.

Fehler -123053 ist bei aufgetreten

Mögliche Ursachen:

NI-Farm: The job state transition is not valid.

Vollständige Aufrufkette:

Start Time: 14:16:38
End Time: 14:16:45
Total Time: 00:00:06,445


I wasn't able to find any description for that kind of communication error (-123053).

What could be a solution to this problem?


I'm using:

- Windows 10 (64bit)

- LabVIEW 2010 SP1

- FPGA 10.0.1

- CRio 9073 as FPGA hardware

0 Kudos
Message 1 of 5

No ideas?

0 Kudos
Message 2 of 5

Hello CRio9073,


Have you tried to compile on another PC?

Can you update the software?

Have you tried to repair the software?

Is .Net 3.5 or later installed?

Reinstalling the software?


1) Go to the Control Panel and open the Add/Remove programs dialog
2) Select "National Instruments Software" and click "Change/Remove"
3) Select and remove all versions of the NI LabVIEW FPGA Xilinx Tools (10.1, 11.5)
4) Delete the C:\NIFPGA\Programs directory. 
5) Restart the computer. 
6) Disable any firewall/antivirus software and anything else that could interfere with the installation
7) Install the Xilinx Tools from the installation media. If possible, use the downloadable installers from, since they will install the latest versions, and only what we need 
😎 Restart the Computer 
9) Launch the compile worker to ensure that it launches and has registered capabilities for Xilinx 10.1 and 11.5
10) Attempt the 2010 FPGA compilation again


Hope this helps.

best regards
0 Kudos
Message 3 of 5

Hi Duffi2007,

sorry for the big delay.

I tried to compile the software on a Win7 System and it worked.

I tried to repair the software and to reinstall, but with no succes.

Firewall/antivirus is the same as on working system.

I'll try to install LabView on a virtual maschine with Win7 and try it again or do you have an other idear?



0 Kudos
Message 4 of 5
Accepted by topic author CRio9073

Hello CRio9073,


in this case, if the uninstall, registry clean and folder delete not helped before fresh installing, then is something wrong in the background. Sorry but then you have to

reinstall the PC or use the VM.

best regards
0 Kudos
Message 5 of 5