LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

cluster behaves like array in lv8.6.1

Hello,

 

I am using cluster having about 40 numerics to save to disk.

 

In LV7.1 If I place a numeric in cluster the data range of that numeric will come Use dafault range Checked. I can remove that check mark and I can change the minimum maximum & increment values as per my requirement. I can copy as much as my requirement of remaining 39 numerics from this first numeric and could change the min, max increment values for each other numeric separately as required.

 

In LV8.6.1 this min, max, increment values I will not able to change it for each numeric. If I change this will reflect in every other numerics. Is it a bug with this version? If so how can i overcome that.

 

 

Kousy

 

 

 

0 Kudos
Message 1 of 13
(1,889 Views)

 

Hi,

 

I tried to reproduce the same thing but it was working fine. I was able to change the data entry fields of all the numerals, and it did take effect. Am I missing anything?

-Mallya

" Appreciate and motivate those who help"
0 Kudos
Message 2 of 13
(1,880 Views)

Hi there

 

Confirmed!

 

Whats even worse: LV keeps the settings for min/max etc. for ALL numeric control! No matter if the control is inside the cluster or on the FP of a completely different VI.

 

I think this is a big one!

 

<edit>

Seen on WinXP SP3, LV 8.6.1 (DevSuite 2009/01)

</edit>

Message Edited by chrisger on 07-07-2009 12:57 AM
Best regards
chris

CL(A)Dly bending G-Force with LabVIEW

famous last words: "oh my god, it is full of stars!"
0 Kudos
Message 3 of 13
(1,877 Views)

Hi there,

 

 

Can you put the steps to reproduce. It is still working fine for me..

-Mallya

" Appreciate and motivate those who help"
0 Kudos
Message 4 of 13
(1,871 Views)
  • create a VI
  • place a cluster on the FP
  • drag a numeric control from the tool box inside to the cluster
  • right click->Data Entry (shows default enabled)
  • set default = FALSE and edit the min, max and increment parameter, press OK
  • drag another numeric control inside to the cluster
  • right click second numeric control ->data entry not default, same parameter values as for control 1, press cancel
  • drag a third numeric control OUTSIDE the cluster
  • right click third numeric control ->data entry not default, same parameter values as for control 1
Best regards
chris

CL(A)Dly bending G-Force with LabVIEW

famous last words: "oh my god, it is full of stars!"
0 Kudos
Message 5 of 13
(1,863 Views)
property nodes return the correct values for the data entry parameters for each control, but the dialog still shows wrong values.
Best regards
chris

CL(A)Dly bending G-Force with LabVIEW

famous last words: "oh my god, it is full of stars!"
0 Kudos
Message 6 of 13
(1,860 Views)

Hi chris,

 

Yes Property nodes returning correct values but when we try to coerce to the maximum value will pose a problem then right. So One thing is sure at any point of time only one control's data entry values is effective and is reflected in all other controls.

 

Which version are you using Mallya?

 

 

Kousy

 

0 Kudos
Message 7 of 13
(1,829 Views)

Hi,

 

I am using 8.6.1... I am still not seeing the problem you are referring..

-Mallya

" Appreciate and motivate those who help"
0 Kudos
Message 8 of 13
(1,827 Views)

Kousy,

 

do you have hotfix 8.6.1f1 installed? If not, please download and install it. You can download the fix here

 

hope this helps,

Norbert 

Norbert
----------------------------------------------------------------------------------------------------
CEO: What exactly is stopping us from doing this?
Expert: Geometry
Marketing Manager: Just ignore it.
Message 9 of 13
(1,819 Views)

Hi Mallya,

 

I am attaching the vi please save with different values for each numeric and send back.

 

 

Kousy

 

 

0 Kudos
Message 10 of 13
(1,812 Views)