LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

cannot communicate with fluke45 multimeter under serial control

Solved!
Go to solution

I am using the fluke "getting started vi" and the error says <ERR> Fluke 45 Initialize
The ID Query failed.  This may mean that
you selected the wrong instrument or
your instrument did not respond. 
You may also be using a model that is
not officially supported by this driver. 
If you are sure that you have selected
the correct instrument and it is
responding, try disabling the ID Query.

I have disabled the ID Query and I still get the same message.I have wired up the serial connector in the conventional way ,is there possibly an alternative wiring config.

0 Kudos
Message 1 of 8
(3,085 Views)
If you truly disabled the ID query, you would not be getting the same message. My guess is that you didn't place a false constant on the block diagram that calls the initialize function. You should at least perform the query in MAX to see what the instrument is actually returning and then compare that to what the initialize VI expects. It's probably a simple matter to change the initialize function.  Post the actual response and initialize function if you need help modifying it.
0 Kudos
Message 2 of 8
(3,072 Views)

I have gone into max & measure opened visa test panel

with the following result:-

read

 count 1024 return count 4 return status 0

 

write

buffer *IDN?\n return count 6 return status 0

0 Kudos
Message 3 of 8
(3,043 Views)
That is sort of interesting but does not really help you solve the problem. You need to look at the text returned and compare it to the expected text in the VI.
0 Kudos
Message 4 of 8
(3,030 Views)

Dennis,

I am not that familiar with the visa test panel so could you please be more specific how  I should use it  correctly.

frank

0 Kudos
Message 5 of 8
(3,019 Views)

Dennis,

To be more specific where do i find the text returned option.

frank

0 Kudos
Message 6 of 8
(3,001 Views)

The text returned is the text that is in the 'Buffer' box on the Read tab.

 

You can also test communication with a terminal emulation program such as Hyperterminal. Just type the command that requests the instrument to send back the identification information (i.e. *IDN?).

0 Kudos
Message 7 of 8
(2,995 Views)
Solution
Accepted by pvdfpmma

Dennis,

Thank you for your help.The problem has been solved , the meter had been configured to even parity instead of none (parity bit 0).

frank

0 Kudos
Message 8 of 8
(2,981 Views)