LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

can anyone plz tell how to bundle a color box?

Solved!
Go to solution

Hi all, 

 

I am trying to pass the color of a color box control from one vi to another vi by bundling it into a cluster and passing the values. There are some other values also which are bundled along with the color. In the second vi when i tried to unbundle the cluster passed from the first vi and then wired the color passed, to a color box, it is getting connected and showing the correct color . But when i am trying to connect the whole bundle to a cluster, it is not gettting connected because of the color box in the cluster. 

 

Can anyone please tell me how to solve this problem. I have herewith attached my 2 vi's which i am working with.

 

Thankful regards,

 

Nitz

Download All
0 Kudos
Message 1 of 2
(2,261 Views)
Solution
Accepted by topic author NitzZ

Hi Nitzy,

 

gaa, I'm color blind now Smiley Wink

 

Well, in your vi2.vi you call a subVI (inputmodule2), which you didn't attach... There's no direct connection between vi1 and vi2...

 

-You also have a big race condition in your vi1 because of all those colorbox locals - when more than one condition is true you can't predict which color is used...

- Why don't you use UnbundleByName?

- VI2 shows no wiring error...

- Why don't you use a cluster in VI for all your inputs? You can hide the border and place the cluster elements in the same way. No need for several locals for initialisation and no need for a bundle node...

Best regards,
GerdW


using LV2016/2019/2021 on Win10/11+cRIO, TestStand2016/2019
Message 2 of 2
(2,255 Views)