LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

cRIO serial write problem

Solved!
Go to solution

I want to communicate between cRIO 9073 and PC,the master will be cRIO. Now am using VISA for communication, My problem is when i write from PC and read in RIO i can able to do. But when i write from RIO and read from PC i could not able to read. No values are coming. I don't know what i am missing. May be speed difference?Do i have to change baud rate? Now i have set to 9600 in both.

Can anyone please help?

Aarthi
0 Kudos
Message 1 of 8
(1,070 Views)

I am not familiar with the Serial communication. My question is you have an ethernet port in your RIO controller so you can use that for communication with the host adn vise versa or do you have any special reason for using Serial communication?

-----

The best solution is the one you find it by yourself
0 Kudos
Message 2 of 8
(1,069 Views)

Actually i have to communicate serial port of RIO with some other device instead of PC.

I am new to this, so just started working with PC, and also i refered this link also.

 

Aarthi
0 Kudos
Message 3 of 8
(1,067 Views)

You have done any code for communcation or you are using only the code from the example code you given (link)?. If you have done any code for that try posting it here.

-----

The best solution is the one you find it by yourself
0 Kudos
Message 4 of 8
(1,059 Views)

when i try to run Read[PC], am getting error as "Could not perform operation because of IO error"
in VISA read function. It is reading one null byte.

Aarthi
Download All
0 Kudos
Message 5 of 8
(1,055 Views)
Solution
Accepted by topic author Aarthi_Arvindh

Still am not familiar with the serial port signals but am trying to help you. just do a trial: Remove the cable from the RIO and just shot the pin numbers 2 and 3 of the serial port cable and run both the code simultaneously in the host. If you are recieving the data properly then the problem might be with the cable option (Straight or cross).

-----

The best solution is the one you find it by yourself
Message 6 of 8
(1,052 Views)

Thanks for helping Anand, i did loopback test in other cable, not with the one
which i am using. Problem is with cable only, transmit pin didnt work.

Aarthi
0 Kudos
Message 7 of 8
(1,046 Views)

Good luck.

-----

The best solution is the one you find it by yourself
0 Kudos
Message 8 of 8
(1,035 Views)