Showing results for 
Search instead for 
Did you mean: 

cRIO RT VI graph/chart not plotting (no x axis)

I have a strange situation. I am trying to do a simple chart or graph on a cRIO (VI on the RT controller).  If I place a chart or graph on the desktop, the x axis labels dissappear and the graph will not plot. If I run a simple example, it appears that the graph is only plotting one point at a time (I see the Y axis autoranging) but I see no plot, nor do I see anything across the bottom axis. It happens only on my cRIO RT. If I run the same program on my PC, it works fine.
I have recently upgraded to 8.2 and upgrade my cRIO also.
Is there something simple that I missed?
0 Kudos
Message 1 of 11
I just ran an application on a cRIO RT target with LV 8.0 on it. There was no problem. I have not tried running it with LV 8.2. It should behave the same way it does on your desktop. Make sure you have all the necessary software installed on your RT target.
Best regards,
Kalin T.
0 Kudos
Message 2 of 11
Thanks for the response Kalin. I'm going to look at this again today. As I said, it worked fine in LV7, so maybe I'm missing a driver.
I recently have problems getting the comm port to work on the cRIO and found out I did not install the serial driver.
The only "complaint" I have about this is that I don't remember being given an option to install it or not. Of course I could simply have not been paying attention Smiley Happy.
In any event, I will look at this more today.
0 Kudos
Message 3 of 11

Ok really weirdness happening.

I installed the following onto the cRIO which apparently I did not have installed:

DataSocket for Labview real time 4.4

Labview PID control Toolkit 8.2

Network Variable Engine

Variable Client support.


After I did this, well, now I see the graph X scale, BUT, the  maximum (default 100) shows up 1/4 of the way across the screen.


See attached pictures.  I can't do anything to change it.


SHould I just reformat and re-install the entire cRIO software ?



0 Kudos
Message 4 of 11


It seems like you have all the correct software. It should work just fine even with only LV RT 8.2 and NI-RIO drivers. I would suggest formating the flash drive, ftp-ing to the flash of the cRIO to make sure there is nothing left, and reinstalling the software.

Hope that helps!

Kalin T.
0 Kudos
Message 5 of 11


This is most likely due to an issue with the application running on the controller.  If you post your code it should be easy to determine why the chart is not updating correctly.  Also just a small question are you using a chart or a graph to plot the points?

Looking to help,


0 Kudos
Message 6 of 11
Ok guys it's working now.
I had to physically move the graph to the left. It was weird, I don't know how it was "moved".
If I moved it to the right, it was as if the "edge" of the viewing area stopped the maximum line of the graph.
I don't know how to explain this so I hope it's understandable.
So, in summary, somehow I moved the graph to the right edge, even though I can put other controls there, the graph maximum line seems to stop and stay as I move the graph right.
Does any of this make sense lol? I'm totaly confused about it, but at least it's working now.
I imagine it has something to do with my desktop.

here's two pictures:
"normal.jpg" is ok
"moved.jpg" is after I've moved the graph to the right.
0 Kudos
Message 7 of 11

Hmm...seems like it might have been a graphics glitch?  Are you currently able to reproduce it again?  If you can reproduce it it might be worth looking into further.




0 Kudos
Message 8 of 11

Hi Steve,

Yes, all I have to do is move the graph to the right and it will do what you see in the picture.

I don't have a good understanding of the Labview workspace, since I am not that experienced with it. I just put graphs and controls wherever they end up. Smiley Happy



0 Kudos
Message 9 of 11
Hi Jeff,
I was not able to reproduce your problem. Most probably there is something wrong with the installation of the supporting software on the real-time target (cRIO carrier). If you have not formatted your flash drive yet, I would encourage you to do so and reinstall all software from scratch.
Best regards,
Kalin T.
0 Kudos
Message 10 of 11