LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

build installer LV2009, requires OLD distribution installation disks?

Highlighted

When building an Installer using LabVIEW 2009, and including additional distributions, why does the installer builder require the original distribution disks from the install DVD/CDs?  Why are the version required not promoted to the LATEST update installed?  This is a real PITA when I have to go find the disks from 1Q2009, no wait, it did not ask for that, it asked for Feb 2009 device drivers disk 2. 

This is as bad as Microsoft for installing from original distributions.  

It is not a good thing to expect that I have to maintain a library of DVDs/CDs for every distribution/update I have ever used.  Especially when I am taking work home, and do not have access to this ENTIRE library, rather a copy of the lasest update ONLY.

 

to National Instruments, Thoughts on this?


Paul <--Always Learning!!!
Philips Respironics.
sense and simplicity.
Browse my sample VIs?
0 Kudos
Message 1 of 6
(1,057 Views)
Highlighted

Paul,

 

You're right. This can be very frustrating. I'm not here to justify why these issues arise or how they're designed but there are a few things I've learned along the way that may help you and others which stumble upon this thread.

 

Have you upgraded or do you have old installs of LabVIEW on your machine? Installing multiple copies of LabVIEW on the same machine can make building distributions difficult. I'm running LabVIEW 8.2.1, 8.6, and 2009 (along with CVI 9.0). Although NI says multiple LabVIEW versions on one machine are supported I would not recommend having this setup as your primary build machine due to the issues you stated above.

 

Drivers and toolkits must be installed on top of LabVIEW. For example, I was running NI-RIO 3.2.1 using LabVIEW 8.6 but upon installing LV2009 I had to come back around and reinstall NI-RIO so that LV2009 acknowledged the drivers.

 

Final, virtualization could be the key to large scale development. If you're in a role which requires you to support several pieces of software running various revision of LabVIEW or drivers there will come a time when your companies disorganization will result in you're need to be hyper-organized. (at least in order to save time and headaches). I'm currently in the process of looking into virtualization software (VMware) in order to keep seperate OS installs for my different products my team supports. Not sure if this will be my final stop in the challenge you presented but like yourself i'm always learning and trying to make things better.

 

Craig

0 Kudos
Message 2 of 6
(1,043 Views)
Highlighted

Thanks Craig... BUT, I only have LabVIEW 2009 Intalled.  although I have upgraded components through the quartely updates.  So while what you say is true... it does NOT necessarly mean that you have 'multiple' versions of the LabVIEW development environment installed

 

That said... I have been at this for a little while (more than a day, but less than the time since dinosaurs walked)... and app building is something that has become much more complicated over time... I want to know WHY NI does not promote the installers/distributions to the most current version on the update DVD/CD where applicable... but you bring up a good point... If it cannot promote the distribution, it should give you a warning and ASK you if you wish to 'cache' the obsolete distribution as it does when building the current distribution.  This gives you an option to cache it WHILE the distribution is handy.

 

Failing that, in the project, there should be an option to have it display the currently required distributions as opposed to having to build the installer object, start the installer build, then wait for it to ask you.... by then it maybe too late.

 

I realize that you are trying to help/offer workarounds... I appreciate what you are trying to do... BUT, in this case, I want NI's people to justify what they are doing and why.  This goes beyond wish list, this requires justification, as even Microsoft has addressed this issue.


Paul <--Always Learning!!!
Philips Respironics.
sense and simplicity.
Browse my sample VIs?
0 Kudos
Message 3 of 6
(1,030 Views)
Highlighted

Paul

 

If you are seeing persistent missing distributions problems when you create installers, you can copy the selected distributions onto your development system so you won't get that message again. Check out this Knowledge Base Article for more details.

 

How Do I Stop the Missing Distribution Notification Each Time I Build An Installer?

 

Hunter | Applications Engineering

0 Kudos
Message 4 of 6
(1,016 Views)

Hunter,

Two things... According to John Pasquerette (sp?).. this is a resolution to resolve in 2010 (installation and distribution headaches).  So how is a workaround resolving it?

 

second thing.... Why should I go out of my way to resolve what is clearly an issue with the way NI deals (or does not deal) with upgrades?

 

bonus... I have told the installation builder to cache the distribution so that is "should" not ask again, yet... in some cases, it still has asked again.  So that is a second issue.  

 

bonus part two... While disk space is fairly cheap, why should I pay extra for NI's shortcomings and mistakes?  They are not giving me a discount for them!!!

 

So while I appreciate you trying to solve my problem (which I have done already), I want to clearly get an answer FROM NI, on why they thought that this approach is a good one?  Why these workarounds are the "resolution" to these issues?  


Paul <--Always Learning!!!
Philips Respironics.
sense and simplicity.
Browse my sample VIs?
0 Kudos
Message 5 of 6
(1,002 Views)
Highlighted

Paul

 

First of all for anyone who doesn't read NI VP, John Pasquarette's blog "Inside LabVIEW", here is the link to his 2010 Resolutions for NI.

 

The resolutions are a list of things he would like NI to focus on for future versions of LabVIEW. The fact that this issue has been one of Pasquarette's resolutions for two years now shows that NI is aware that we have a lot of room for improvement with LabVIEW upgrades.

 

In the mean time we will use this workaround to get the application builder working, but any workaround, by definition, is not a long term solution.

 

If you have feedback on how we should improve this process please post a product suggestion (goes to LV R&D) or create an Idea on the Idea exchange (viewable by all LabVIEW users). You can also post a comment on John's blog.

 

Hunter Smith

Applications Engineer

0 Kudos
Message 6 of 6
(973 Views)