Showing results for 
Search instead for 
Did you mean: 

application runs in NT but not win95

I created an application and got it working on an NT machine but then when I
tried to install it on a win95 machine it wouldn't work. When I try
starting it it asks for hp816x_32. I don't know if it is relevant but it
leaves off the extension when it asks. So I show it where hp816x_32.dll is
but it acts like thats not right because it says functions are missing and
also it keeps asking for it (about 8 times). I've tried reinstalling the
dll from the agilent/hp driver disk, and I've tried recompiling the
application with the dll included. When I include the dll it no longer asks
for it, but it still gives the error messages 8 times. According to the
agilent cd it should work for both nt and 95. Is there something I'm
missing her
0 Kudos
Message 1 of 3

I have had a similar with a non-NI board myself. It turns out, the dlls were built for NT, but had a W9x equivalent. You may find that you have to dig deep into your VIs and either replace the one that is giving the problem, or even reconfigure the dll to call the correct version.

When you do platform specific development (even when you don't realize it's platform specific), you have to take this kind of thing into consideration.

Good luck, and let us know if you are still stuck.
0 Kudos
Message 2 of 3
One thing that I know is that plug and play drivers on NT systems get installed to VXIpnp\winnt and on win95/98 get installed to VXIpnp\win95. It sounds to me that something is looking for a folder that doesn't exist. I would try locating the driver in the same location as the VI calling it.
0 Kudos
Message 3 of 3