LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

application builder & DLL

I use a DLL compiled with Delphi in some VIs.
It is OK when my VI runs in Labview environment (any version).
But when I compile my application with Application Builder I have sometime
(1/2) an execution erreur if:
-The version is 5.1 (works fine with 5.0)
-The VI contains a chart or a graph
-The DLL is compiled with Delphi (3.00 or 5.00, works fine with C++, but I
prefer Delphi!)

This problem exits for ALL THE DLL compiled with Delphi.
NI understood that there is a problem but has not yet answered.
Did anyone have the same problem?
--
Philippe BREUIL
Centre SPIN, Ecole Nationale Superieure des Mines de Saint-Etienne
158 cours Fauriel, 42023 St-Etienne cedex 2 FRANCE
tel (33) (0)4 77 42 01 51
fax (33) (0)4 77 42 00 00
pbreuil@
emse.fr
www.emse.fr/ECOLE/FRENCH/SPIN/index.htm
0 Kudos
Message 1 of 3
(1,526 Views)
I have the same problem, only my dlls are written with Borland C++
Builder.
I was on tech support with NI for weeks over this, and even sent them
a small app which demonstrated the bug. Bottom line is, their
developers are aware of it, but there is no solution when using 5.1
I switched back to 5.0 for any app that calls a Borland dll
On Fri, 10 Mar 2000 17:06:11 +0100, "Philippe BREUIL"
wrote:

>I use a DLL compiled with Delphi in some VIs.
>It is OK when my VI runs in Labview environment (any version).
>But when I compile my application with Application Builder I have sometime
>(1/2) an execution erreur if:
> -The version is 5.1 (works fine with 5.0)
> -The VI contains a chart or a graph
> -The DLL is compiled with Delphi (3.00 or 5.00, works fin
e with C++, but I
>prefer Delphi!)
>
>This problem exits for ALL THE DLL compiled with Delphi.
>NI understood that there is a problem but has not yet answered.
>Did anyone have the same problem?
>--
>Philippe BREUIL
>Centre SPIN, Ecole Nationale Superieure des Mines de Saint-Etienne
>158 cours Fauriel, 42023 St-Etienne cedex 2 FRANCE
>tel (33) (0)4 77 42 01 51
>fax (33) (0)4 77 42 00 00
>pbreuil@emse.fr
>www.emse.fr/ECOLE/FRENCH/SPIN/index.htm
>
>
0 Kudos
Message 2 of 3
(1,526 Views)
Have you tried the upgrade to 5.1.1? This makes some significant changes
and fixes to the way app builder works.

dtrickey@snet.net (Dave Trickey) wrote:
>I have the same problem, only my dlls are written with Borland C++>Builder.>I
was on tech support with NI for weeks over this, and even sent them>a small
app which demonstrated the bug. Bottom line is, their>developers are aware
of it, but there is no solution when using 5.1>I switched back to 5.0 for
any app that calls a Borland dll>On Fri, 10 Mar 2000 17:06:11 +0100, "Philippe
BREUIL"> wrote:>>>I use a DLL compiled with Delphi in some
VIs.>>It is OK when my VI runs in Labview environment (any version).>>But
when I compile my application with Application Builder I have sometime>>(1/2)

an execution erreur if:>> -The version is 5.1 (works fine with 5.0)>> -The
VI contains a chart or a graph>> -The DLL is compiled with Delphi (3.00 or
5.00, works fine with C++, but I>>prefer Delphi!)>>>>This problem exits for
ALL THE DLL compiled with Delphi.>>NI understood that there is a problem
but has not yet answered.>>Did anyone have the same problem?>>-->>Philippe
BREUIL>>Centre SPIN, Ecole Nationale Superieure des Mines de Saint-Etienne>>158
cours Fauriel, 42023 St-Etienne cedex 2 FRANCE>>tel (33) (0)4 77 42 01 51>>fax
(33) (0)4 77 42 00 00>>pbreuil@emse.fr>>www.emse.fr/ECOLE/FRENCH/SPIN/index.htm>>>>>
0 Kudos
Message 3 of 3
(1,526 Views)