Showing results for 
Search instead for 
Did you mean: 


Go to solution



I have written a simple program for receiving and transmitting CAN frames. I have a device on the CAN bus and am able to receive messages from the device just fine. When I try to write a frame to the bus to make the device do something, I notice that my broadcast message on the bus does not use the ID I had set in the CAN frame.


For example, I am writing a frame to the bus with ID 18FEDF55, which should start a heater function on the device. When I monitor the CAN bus however, my broadcast message does not show up as coming from ID 18FEDF55, but from ID 755. If I change the ID to 18FEDF00 then my broadcast message looks like it coming from ID 700 when I monitor the bus.


I had made a similar program in the past using NI CAN, which used a similar frame, and it worked. When I changed the ID in the frame, it was put on the bus with that ID. This does not appear to be working the same with XNET.


Anyone have any suggestions what is going on here or how to correct it?


Thanks in advance.



Download All
0 Kudos
Message 1 of 3
Accepted by StevoP80

You need to set the extended ID to true

Message 2 of 3

@OEM_Dev wrote:

You need to set the extended ID to true

You know, over the weekend in trying out some of the different session options, I am positive I tried that and had no luck. As soon as I read your reply I clicked the extend button and tried again and it worked. Ugh.... I should have tried a couple more things before posting lol.


Thanks for the help!

0 Kudos
Message 3 of 3