LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Windows_10 + PXI-7841R + LabVIEW 2019 : NI says need Xilinx Compilation Tool for ISE14.7, but only Windows_7 ?!

Solved!
Go to solution

Good Day,

 

I have a PXI-7841R FPGA device, LabVIEW 2019 installed, and NI says at Compatibility between Xilinx Compilation Tools and NI FPGA Hardware - NI that requires the Xilinx Compilation Tool for ISE 14.7. It also says that Module Xilinx Compilation Tool for ISE 14.7 is not supported on Windows_10

 

Our IT will not allow me to use Windows_7. Does someone have a work-around? If I upgrade LabVIEW would there be a solution? 

 

Thank you in advance for your insight.

0 Kudos
Message 1 of 7
(157 Views)

If you have an active SSP, you can use the NI online compile server.

 

https://www.ni.com/en-us/support/documentation/supplemental/14/compile-faster-with-the-labview-fpga-...

-Santhosh
Semiconductor Validation & Production Test
Soliton Technologies
NI CLD, CTD
LabVIEW + TestStand + TestStand Semiconductor Module (2013 - 2020)
NI STS for Mixed signal and RF

New to the forum? Please read community guidelines and how to ask smart questions
Message 2 of 7
(150 Views)

That is a great idea. Thank you for bringing it up. Our IT does not allow us to use that service at this time.

0 Kudos
Message 3 of 7
(131 Views)

If your IT does not allow you to use NI online compile service, you may be cornered to setting up your own FPGA compile farm on Linux on a local server.

-Santhosh
Semiconductor Validation & Production Test
Soliton Technologies
NI CLD, CTD
LabVIEW + TestStand + TestStand Semiconductor Module (2013 - 2020)
NI STS for Mixed signal and RF

New to the forum? Please read community guidelines and how to ask smart questions
Message 4 of 7
(118 Views)

Santhosh, That is another great idea. I will consider it once I have exhausted all more straight forward options though, as I would have to get IT involved.

 

https://www.xilinx.com/support/download/index.html/content/xilinx/en/downloadNav/vivado-design-tools...  says that 

ISE Design Suite for Windows 10 - 14.7 

Last Updated February 2020

 

This version of ISE supports all Xilinx devices. For more information, visit the ISE Design Suite.

So this could work, but when I run the installer it says it is going to install a virtual machine. Will the NI FPGA compile worker know how to access it? 

ISE 147 Win10 VM installer.png

0 Kudos
Message 5 of 7
(96 Views)
Solution
Accepted by topic author FrankBrown

We are using Virtual Machines with Windows 7 for this purpose. Don't know if that's allowed by your IT.

You could then either develop in the VM, or just use this as compile server.

 

Message 6 of 7
(76 Views)

Thank you Dan,

 

This is what we should do indeed, setup a compile server.

But after thinking a lot about this, and to keep things simple, I will replace the 7841R with a 7846R:  The 7846R compiles in Windows10 with LabVIEW 2019 and the "LabVIEW 2019 FPGA Module Xilinx Compilation Tool for Vivado": So no need to authorize and setup a compile server for now.

 

This tool made me realize that different FPGA cards may require different compile tools:

Compatibility between Xilinx Compilation Tools and NI FPGA Hardware - NI

0 Kudos
Message 7 of 7
(47 Views)