LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Why does ungroup on a pane move all objects randomly to the side?

Hi all,
 
Whenever I do an "ungroup" function to a group of controls that is located on one pane of a tab control, they all get moved over to the side for some reason.  This is a real pain in the rear.  The only way I can figure out how to fix this is to move the group completely off of the tab onto the main background, then ungroup, then modify, then group, then move it back.
 
Has anyone else experinced this bug?
 
Thanks,
 
Jason
0 Kudos
Message 1 of 7
(3,130 Views)
Yes, this bug has been seen. See http://forums.ni.com/ni/board/message?board.id=170&message.id=166513&query.id=51088#M166513
Andrew Alford
Production Test Engineering Technologist
Sustainable Energy Technologies
www.sustainableenergy.com
0 Kudos
Message 2 of 7
(3,121 Views)

And since the AEs are now posting IDs of the bug reports, I'll go ahead and share that...it's 3T7IQGA5.  The problem should be fixed in a future LabVIEW version.  For now, the only workaround is to move the controls out of the tab control before ungrouping, then move them back in.

-D

Message 3 of 7
(3,115 Views)
I have not had this problem with the tabs in Version 7.0 it might have to do with your autosettings on the tab options.  Something similar happens with clusters when you have the vertical and horizontal arrange selected.  Labview might be trying to auto arrange your controls, this most likely can be turned off but I dont have LV opened right now to test it.
 
Paul
Paul Falkenstein
Coleman Technologies Inc.
CLA, CPI, AIA-Vision
Labview 4.0- 2013, RT, Vision, FPGA
0 Kudos
Message 4 of 7
(3,115 Views)

I don't think the problem has to do with any LabVIEW settings.  I believe it is simply a bug with the Ungroup feature with Tab Controls specific to LabVIEW 8.0.

-D

Message 5 of 7
(3,110 Views)

OK something to look forward to, I didnt see it in LV 7.0

Paul

Paul Falkenstein
Coleman Technologies Inc.
CLA, CPI, AIA-Vision
Labview 4.0- 2013, RT, Vision, FPGA
0 Kudos
Message 6 of 7
(3,095 Views)
This was reported to R&D (# 3T7IQGA5) and was fixed in LabVIEW 8.2. Here is a link to the current evaluation software download for LabVIEW.

Thanks!
Travis H.
LabVIEW R&D
National Instruments
0 Kudos
Message 7 of 7
(2,935 Views)