LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Why does NI Update Service not list the LabVIEW 2015 SP1 f5 patch?

Troubleshooting an run-time problem I noticed that while my development environment which I keep updated using NI Update Service was LabVIEW 2015 SP1f1 - the run-time engine available on ni.com was at fix 5 (LabVIEW SP1 f5). A manual search revealed an f5 patch available for the development environment too, but it is not listed by NI Update Service...(nor have I seen any other since patch f1). Not under critical updates, nor under Upgrades and service packs.

 

As soon as LabVIEW 2016 was out NI Update showed *that* as an update path  (a path I will not use as I will always keep the previous versions untouched, and rather install 2016 in addition to it or on a different machine (should be an option to do that instead of updating by the way)), but still not any of patches.

 

How come? Is the patch not considered critical, nor an update - so it ends up in no category in the Update Service?

 

 

Message 1 of 11
(2,110 Views)

Dear Mads,

When you install NI software, you are given the option to ‘Allow National Instruments to search for important updates’, can you remember if this box was checked?

Please use the link below to manually install the LabVIEW 2016 SP1 (32-bit) f5 Patch:

http://www.ni.com/download/labview-development-system-2015-sp1/6109/en/

 

Best regards,

Tom

0 Kudos
Message 2 of 11
(2,030 Views)

Sure, I know that. Do you get the f5 patch as an option?

 

The NI Updater is set to do an automatic search on every restart, and we also manually run it every now and then. However the f5 patch has never been discovered. I found out by accident that there was a patch and installed it then without the NI Updater.

0 Kudos
Message 3 of 11
(2,022 Views)

Dear Mads,

It appeared on my computer. Are you using the latest version of NI Update Service 15.0 (link below)?

http://www.ni.com/download/ni-update-service-15.0/2617/en/

 

Best regards,

Tom

0 Kudos
Message 4 of 11
(2,014 Views)

Same problem.  Running version 16.0.0.33 of Update Service.  No patches after f1 showed up for 2015SP1.

Win7 SP1 64bit machine with 32bit versiona of LabVIEW 2013SP1, 2014SP1 and 2015SP1 dev systms installed.

Message 5 of 11
(2,002 Views)

Same problem now with 2016 f1 patch...does not show up in NI Updater (nor is there any updates for the updater itself...).

0 Kudos
Message 6 of 11
(1,753 Views)

If I recall correctly, some patches are for combinations of software and/or specifically.  It could be that the updates decided that patch was not necessary.

Bill
CLD
(Mid-Level minion.)
My support system ensures that I don't look totally incompetent.
Proud to say that I've progressed beyond knowing just enough to be dangerous. I now know enough to know that I have no clue about anything at all.
Humble author of the CLAD Nugget.
0 Kudos
Message 7 of 11
(1,741 Views)

I also didn't see 2015 f5 or 2016 f1 in NI Update Service, which for me is at version 16.0.0.33. I also don't see either of these patches here: http://www.ni.com/white-paper/13503/en/

Maybe they're not considered important enough?

0 Kudos
Message 8 of 11
(1,718 Views)

It could be a bug in the updater, it could be caused by some unique combination of factors that affect the updater, or the updater might be (too) selective as you say arteitle.

Only someone from NI can answer that.

 

In my opinion the updater should list every applicable update, and let the users decide if they want to apply them or not.  I noticed 2016 f1 only because a post mentioned that it was required for some sample code to work (new type of channel wire), so it is clearly nice to have...

0 Kudos
Message 9 of 11
(1,693 Views)

Does anyone know where I can find the f5 patch details? I guess they should be listed here but for some reason they're not. I would like to know what fixes were included.

Lucian
CLA
0 Kudos
Message 10 of 11
(1,679 Views)