LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Why does FP Advise sometimes erroneously return terminated?

I am running a multi-threaded LV 5.1 app with fieldpoint and a NI-4060 dmm. Sometimes, the first call to FP Advise returns terminated as true. This never happened when using a NI-4050 dmm. Are there other interactions between these two systems I need to know about?
0 Kudos
Message 1 of 2
(2,202 Views)
The FieldPoint driver is totally independant of the drivers for the NI-4050 DMM, there should be no interaction between them at all. A couple of questions, what are you using as the Advise Rate input to the FP Advise.vi, a rate that is too small (e.g. 0) can sometimes cause erroneous behavior. To avoid this, the default is set to 10 ms starting in FieldPoint Explorer 2.0.3 or 2.0.4, but if you are using an older version, this may be the cause. What version of FieldPoint Explorer are you using? Alternatively, how many I/O points are in your IAK file and what type of network module are you using. An extremely large IAK (e.g. several hundred to several thousand points) that has numerous ethernet points will take longer to launch the server so it is possible that the
server has not finished connecting to all of the I/O points by the time you do the first advise which could return the improper information that the server is not online ("terminated"). If this is the case, a small delay before you start the Advise should clear this up.

Regards,
Aaron
0 Kudos
Message 2 of 2
(2,202 Views)