Showing results for 
Search instead for 
Did you mean: 

Why do I get "you have connected two terminals of different types"

Why do I get the above error when the error box defines both source and sink as being the same type. It is occurring twice on the attached VI. See text on block diagram for the two locations with broken wires.
0 Kudos
Message 1 of 21
You have "indexing enabled" on the two inputs in question into your for loop. Right click on each input and select "disable indexing". This will cause the input to come in as an array.
Message 2 of 21
I'm getting a similar message.
The VI used is this: 
Temperature from NI example finder.
Using a FP-TC-120 with k type thermocouple and LabView 7.1 and latest software I can read the temperatures in MAX but get the old You have connected 2 terminals of different types.
These cannot be wired together because their data types (numeric, string, array, cluster, etc.) do not match.  Show the Context Help window to see what data type is required.
The type of the source is FieldPoint IO.
The type of the sink is void.
error when I try to run it.  (Broken wire is clearly visable). 
I tried it with these two settings also,
FieldPoint\FP @ 169_254_0_2\FP-TC-120 @1\Thermocouple type @Channel 0 2
FieldPoint\FP @ 169_254_0_2\FP-TC-120 @1\Channel 0
and still get the broken wire / incompatable terminal types message.  I even tried taking the advice above, concerning 'disable indexing' at the tunnel.  However when attempting this the option is there (well enable indexing is) but in faded text, as it is not selectable.  Any other ideas how I can test my system out and run a simple display temperature on screen?
0 Kudos
Message 3 of 21

Did you modify the example? Which wire is broken?

Could you post maybe a screenshot (no bmp please)?

Using LV8.0
Don't be afraid to rate a good answer... 😉
0 Kudos
Message 4 of 21
No, it wasn't modified.  I just used browse to insert the temp probe selection.  Got a screenie for you though, jpeg format. Smiley Wink   The wee purple bridge is where I attempted to right click and 'disable indexing' but the option was faded, and so unavailable.
thanks so far 🙂
0 Kudos
Message 5 of 21
If you right-click the FP-VI select "Select Type" in the context menu. There you can select the type you want to use (Automatic should work best).
I'm sure the FP-tag doesn't match the datatype to acquire.
Using LV8.0
Don't be afraid to rate a good answer... 😉
0 Kudos
Message 6 of 21
Just tried it luck.  Theres something small and daft I'm missing somewhere, but I cannot think what! Smiley Mad  Smiley Happy    
0 Kudos
Message 7 of 21
Have a look at the errors-window. What is the detailed description if you select the error of the two different terminals?
Using LV8.0
Don't be afraid to rate a good answer... 😉
0 Kudos
Message 8 of 21

Hope this screenshot is what you mean.  Thanks for the help so far by the way 🙂


Jpeg format again.




0 Kudos
Message 9 of 21
Long shot,

try disconnecting the FP VI, delete it and then replace it with the same function again.  Now wire up and see what happens.

Long shot, like I said.

Hope this helps

Using LV 6.1 and 8.2.1 on W2k (SP4) and WXP (SP2)
0 Kudos
Message 10 of 21