LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

When trying to save my VI/Project i get the error message "cannot load help of *.VI"

As the tittle says i get the error message when saving a VI. This prevents me from being able to save my project. Is there a workaround for this?

0 Kudos
Message 1 of 7
(1,717 Views)

I have gotten odd errors which may be similar, something along the lines of "cannot save VI with corrupted block diagram". It is weird, because I could see the block diagram of the VI just fine. I ended up making a new VI, copy and paste the block diagram, then replace the old VI with the new VI everywhere it is called (hopefully not many places). Have you tried this?

0 Kudos
Message 2 of 7
(1,709 Views)

I have tried copy/pasting, but not all structures are actually copies and pasted. Fixing what is not copied would actually be more work than just fixing whats lost.

0 Kudos
Message 3 of 7
(1,639 Views)

Hi spastichawk,

 

check the VI properties of the VI causing the error message!

Under "documentation" you can set a help file for this specific VI: check this path for file presence…

Best regards,
GerdW

using LV2011SP1 + LV2017 (+LV2020 sometimes) on Win10+cRIO
0 Kudos
Message 4 of 7
(1,636 Views)

There was no file specified. I did point it to the related help documentation (VI was started from simple state machine example), but no success. Is tehre some way of forcing it that no help file is needed?

 

0 Kudos
Message 5 of 7
(1,629 Views)

Hi spastichawk,

 

Which VI is missing its help files? Is it one of the example VIs or one of your own? 

0 Kudos
Message 6 of 7
(1,603 Views)

It was the simple state machine template vi.

0 Kudos
Message 7 of 7
(1,593 Views)