LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

What does the lvpng.dll library do?

Highlighted
I created a .exe (Labview 6.i) and it contains a print report vi. This vi as I understand, uses the default printer if not directed otherwise. The print function works on my Windows 95 OS, but when it was sent to another site using Windows 98, the print function no longer worked. Any suggestions as to what might be wrong? They do have a default printer selected.
0 Kudos
Message 1 of 4
(1,114 Views)
Highlighted
When you say that the print function didn't work, was there an error code generated? I'm assuming that you are using the print report.vi supplied with labview... in which case there is an error output from this VI. Now maybe you don't have this connected to the higher level VI's, but if the print function isn't working, this may be a good place to start looking for a problem.
Either put a breakpoint/trace on the print report.vi, and step it through the print attempt, or bring the error terminal out to the front panel VI, in either case you should then be able to see any errors that occur...
Message 2 of 4
(1,114 Views)
Highlighted
In addition to slaine's advise, make sure you wire the error clusters throughout your VIs. The problem may be earlier on in the report generation.
0 Kudos
Message 3 of 4
(1,114 Views)
Highlighted
I got an error of image.cpp line 11472, it said to come here and find the solution. Right now I am trying one suggestion which is to re-install the vs. 6.0.2 that I once installed and replace the lvrt.msi file with a new one, then recompile my .exe. I don't know if this will work yet.
0 Kudos
Message 4 of 4
(1,114 Views)