LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Weird problem installing 64 bit vision

Hello,

 

I have a license for 64 bit LV and the vision development module.  I have a new test system, and installed LV as I normally do, and for some reason, the vision module did not install???

 

Windows 7, 64 bit. 

It had a 32 bit version installed with vision, which I did not touch.

I ran through the disks as a normal install, rebooted and validated.

LV works as expected the in license manager shows all activated.  But, vision does not show up, and all my previously written code with vision does not work, and the menus show none of the vision, even the default controls and vision pallets do not show.

 

Any thoughts?  I am in the process of a removal of all NI software and try another install. (This is my third attempt at installing, including installing an older 64 bit version which worked before.)

 

Weird....

 

-- brett

 

0 Kudos
Message 1 of 5
(1,165 Views)

Hello Brett,

 

I believe that the Vision VIs will not show up in the LabVIEW 64-Bit palette unless the Vision Development Module is the 64-Bit installation. Each Vision Development Module installation is separated by 32-Bit and 64-Bit versions. So 32-Bit Vis show up in LabVIEW 32-Bit and likewise for LabVIEW 64-Bit.

 

Regards,

 

Jeff L.

0 Kudos
Message 2 of 5
(1,141 Views)

And yes, that is the case, the 32 bit install does show vision.  But, I have the license for 64 bit vision, and have installed it before. I am using the DS2 distribution, and I thought it would automatically install the 64 bit version of both LV and Vision.  I just did a clean uninstall of everything, and tried to reinstall and still does not work.

 

I even did a custom install, and it did not want to install the 64 bit version, it defaulted to the 32 bit version.  I do have an earlier DVD distribution (2010) where the 64 bit version is on a seperate disk.  But, I believe the newest distributions have both on the same disk.

 

Help!  🙂

 

-- brett

 

0 Kudos
Message 3 of 5
(1,137 Views)

Hi Brett,

 

So if the corresponding version of LabVIEW is installed (in this case 64-bit), then when you choose to install Vision in the Developer's Suite installer, that should by default install VDM support for that exact version of LabVIEW. So it might be easiest to avoid choosing customization and to go right for a default installation. You can do it manually, but be sure to check the precise LabVIEW version.

Ravi A.
National Instruments | Applications Engineer
0 Kudos
Message 4 of 5
(1,121 Views)

I did try both the default and custom installs, and the same result.

 

I finally got it to work.  I used the old distribution of 64 bit (when it was a seperate install disk) and then installed the vision from an old distribution, when it also was on a seperate disk.  This finally worked.  I now have a working installation of both LV and VDM 64 bit.  Only took several hours of time.  😞

 

Still, I have done this before, and this is the first time it happened.  Still don't know what caused it.

 

But, bottom line, I am up and working now.  Thanks for the help.

 

-- brett

 

0 Kudos
Message 5 of 5
(1,112 Views)