LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Webservice upload file post multipart error

I am making a webservice with LV2020-32 and I have created a VI that serves a html form to a browser. The form markup uses POST and the form attribute enctype="multipart/form-data", which supposedly is required if you want to upload a file. The POST request is handled by another vi, but it never receives the file. If I call "Read Postdata.vi" I actually also get an error -67032 that states that the NI webservice does not support multipart bodies. This is not true, because "read all form data.vi" will accept the multipart body.  It will however not return any uploaded files.

 

Lastly, I tried the "Read uploaded files.vi", but it, too, never returns any uploaded files. It gave met error -67023 too: An operating system exception encountered.

 

I also tried "enable CORS for all origins" just to rule out that the browser is making a distinction in content based on mime-type.

I have checked the POST request made by the HTML form, which is completely fine.

 

Any ideas anyone?

0 Kudos
Message 1 of 3
(185 Views)

I wonder why there's not one response to my question so far. It seems like a fairly basic thing to do with a webserver. The webservice toolkit even has a VI to return the uploaded files. It really should be quite simple to upload a file through a webform. What am I missing?

0 Kudos
Message 2 of 3
(113 Views)

By adding a response myself, NI no longer got a trigger to provide support on this question. I am really surprised that there is no response at all on this question.

 

I did find out that behind the NI web server there is a basic install of Systemlink. Maybe the ability to upload files depends on settings inside Systemlink instead. However, I can't find any relevant documentation on this particular subject.

0 Kudos
Message 3 of 3
(68 Views)