LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Web service: unable to resolve from current dialog

Solved!
Go to solution

I'm trying to test out a simple RESTful web service built with Labview.  I tried running the examples (address book, weather station).  When I get to the step of deploying the web service, I get the conflict resolution dialog containing the unhelpful message "unable to resolve from current dialog".

 

I thought perhaps this was a problem with an incompatibilty (e.g. if the example was built for an older version Labview).  I built my own very simple VI containing just one indicator.  I thought it was also a good idea to avoid shared variables.  I still get the same error dialog when trying to deploy the application.

 

 I'm attaching my simple test project in case that helps.

0 Kudos
Message 1 of 5
(4,342 Views)

This is a generic error message. if you look at the bottom of this dialog, there should be a "conflict message" test box with a long description of the actual error.  What is that saying?

 

Also, which version of LabVIEW are you in?

0 Kudos
Message 2 of 5
(4,340 Views)

There is a grey box below the title "Conflict message".  Nothing is inside that box.  I'm using LabView Developer Suite 2011.

 

Edit: attaching  screenshot in case that helps.

0 Kudos
Message 3 of 5
(4,338 Views)
Solution
Accepted by topic author nascheme

There is a known issue in LV 2011 with that string being empty. If it is, that tells us that the LabVIEW Web Server is up and running, but the LV Deployment Web Service is not. Not sure why this would be happening on your system. One thing you can look at to help narrow it down is your Windows event logs.

 

Assuming Win7 or Vista --> in Run type eventvwr.msc.  This will pull up the event viewer. Select 'Application" under Windows Logs. You should see a bunch of warnings and erros in the dialog.  Try to deploy your VI again with this veiwer up, and see if any new error are reported. The Source of the error should be LabVIEW, and I would expect to see http error 400 or 500.

 

outside of LV Dev Suite 2011, do you have anything else installed on your system? Maybe an older version of LV? What OS are you on?

 

Message 4 of 5
(4,332 Views)

Thanks for the help.  Rebooting Windows fixed the problem.  I guess I should have tried that at some point (been a Unix developer for too long now). 😉

 

I think the service was running because going to http://localhost:8080/<something> gave me a HTTP 404 error.  I guess something else was screwed up with the NI related services.

0 Kudos
Message 5 of 5
(4,326 Views)