Showing results for 
Search instead for 
Did you mean: 

Web service error -67305

This is not a question but an experience.

In LV2013 web service I have a vi that sends XML to the client. As LV adds <terminal name>= in front of the output when using the terminal text output, I changed to streaming output.

Everything goes well when typing the URL in the browser, but when doing the same from js, you get an error that has to do with CORS

Access-Control-Allow-Origin is not allowed. In some other post Chris Larson explained the solutions and the most practical for me was to send the appropriate header to the client.


This was working for the terminal output, but not for the streaming output, the error did not go away. It appeared LV created an error -67305 (LabVIEW Web Services: Function not available for service VIs configured for headerless mode. The function attempted by the Web service method is not available for Web service methods configured for headerless mode.) and was not sending the header.

The "Send Headers" option in the output properties did not make any difference, but the "Use Buffer" option does! I selected it, added the Flush Buffer vi and everything worked.

Somebody in the programming department seems to have been messing with the options.

0 Kudos
Message 1 of 5

hi! which forum Chris Larson explained the solutions and the most practical for you was to send the appropriate header to the client, about CORS?
Can you put a link?


0 Kudos
Message 2 of 5

Hello Zehv,


I found this to be the case also and I am using LV 2014.  Maybe a CAR should be filed for this?



0 Kudos
Message 3 of 5



Old topic, but I found this very same error in my LabView 2014. Was the CAR ever filled?

When using the "Stream" output option in the HTTT Method VI Settings, the "Buffered" checkbox shouldn't affect to whether the headers are sent or not.



Message 4 of 5

Same problem here encountered with LV2018 while trying to "Set  HTTP Header" on a method configured for streaming. If the "Buffered" option is unchecked in the Output Type tab of the HTTP method, LabVIEW gives me this error even though "Use headers" is checked. Any news on this? 

0 Kudos
Message 5 of 5