LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Web Services in LabVIEW 2011

Solved!
Go to solution

Hello,

 

I developed an main application, which is streaming output array through network shared variable to small application which streaming same array in XML format as a web service.

It was running fine when made an installer in LabVIEW 2010.

But now i am trying to make an installer in LabVIEW 2011, application running on remote machine and can see web service deployed in /National Instrument/aws/ folder.

I cant see no data at all & distributed manager says good quality of deployed shared variable.

 

Is there any specfic changes in LabVIEW 2011 for making an installer.

 

Thanks

Puneet

0 Kudos
Message 1 of 9
(1,469 Views)

Hi, 

 

I Installed LabVIEW 2010, build web service installer with same code, its working.

Quite sure something has been changed in LabVIEW 2011, is there any body tell me the difference.

 

 

0 Kudos
Message 2 of 9
(1,446 Views)

Hello Puneet,

 

I tried to create a similar situation to what you described, but could not reproduce your issue. I created a new project with a network shared variable (an array of int32), a main.vi that writes whatever the user enters to the variable, and a service.vi that reads from the variable. From the service.vi I created a web service build specification to output XML, and from the main.vi I created an application build specification, including the variables lvlib in the Shared Variable Deployment page. Then I created an installer build specification, which included both the application and web service build specifications.

 

After installing and running the application, I was able to call the web service and see the latest data whether I built the application/installer in LabVIEW 2010 or 2011.

 

Could you please provide more information about how your project is set up or maybe include some code that shows the problem you are experiencing?

0 Kudos
Message 3 of 9
(1,435 Views)

Also, if you haven't already done so, you may want to install the latest patch for LabVIEW 2011. You should be able to get the f2 patch here: http://digital.ni.com/public.nsf/allkb/6BEF4B41E21B828C862578FC0066DF5C.

0 Kudos
Message 4 of 9
(1,430 Views)

Hi,

 

Thanks for your reply.

Have you installed web service installer on remote PC  or LabVIEW development machine.

As Installer is working on development machine with LabVIEW 2011 but when I am installing on other machine, its not working.

 

0 Kudos
Message 5 of 9
(1,421 Views)

Puneet,

 

Make sure you rebuild the web service in 2011 before building the installer in 2011, or it may install the 2010 version of your web service instead, which will fail to load if you don't have the 2010 run-time installed (but it will still be in the aws folder). Let me know if this helps.

 

I just tried running the installer on a remote PC that only had the 2011 run-time engine already installed, and was able to call the web service as before.

0 Kudos
Message 6 of 9
(1,403 Views)

Thanks, can you please let me know which additional installars you have selected while building application.

0 Kudos
Message 7 of 9
(1,389 Views)

I didn't select any additional installers, since I had already installed the 2011 run-time engine installed on the remote machine. However, I also just tried it with the additional installers for the 2011 run-time engine and the NI Variable Engine. When I ran the installer on a clean (no NI software) remote machine, the application and web service also worked.

 

When your application runs, does it deploy the share variable library? Do you receive any error messages when calling your web service (like not found)?

0 Kudos
Message 8 of 9
(1,380 Views)
Solution
Accepted by topic author Puneet_K

Yes, My Application deployed all shared variable and have seen all in good health in Distributed System Manager.

0 Kudos
Message 9 of 9
(1,374 Views)