Showing results for 
Search instead for 
Did you mean: 

Web Service - keep loading

recently i came across web service idea and start working toward monitor my data online. 


i have 144 sensors that feeding a PCB and i'm using A0 analogue input from Arduino UNO to manage what i want to do with those sensors. 


i designed my VI to display a map for those sensors over intensity graph. 

as i'm working with very large VI, i created a global variable that read the same data that displaying over intensity graph and i fed that to Web Service VI. 


i'm not familiar with web service functionality but i followed the procedures that i found it on both or YouTube. 


in my project, i created a new web service, in the web service and i called it (Real Time) and after that in the Web Resources, i build a new VI and i saved it in the right directory. 

in the block diagram i fed the global variable to a new intensity graph. i mapped the connectors to make the intensity graph as an output.


after that, i started the Real Time (web service) then i navigate to the VI and i copied the Method URL. I ran my actual VI and i checked that the global variable running. 

i pasted my Link in the browser , but i couldn't see my results as the browser kept loading all the time. 


i tried another computer, still kept loading. 


i checked if i can see the other computer through ping it and i received a full package back. 


i went to LabView Help and checked the examples, i tried to run the address book example. however, when i'm trying to publish it, i'm having a problem. 


i tried to deactivate the firewall and still have the same problem, i was trying to solve this problem for the last 3 days. 



any suggesting could help me. 





0 Kudos
Message 1 of 4



Just a little information regarding the web-services connection. LabVIEW created Web Services will use TCP port 8080 by default, so that's the port you'll need to allow through your firewall. You shouldn't then need to turn off your firewall during your testing.





0 Kudos
Message 2 of 4

Hi Jack, 


thanks for your reply. I tried all the steps that might come to your mind. 


even i checked my firewall and checked the accessibility of the ports, still can't manage to see my application. 

0 Kudos
Message 3 of 4

after i checked everything with my VI and tried to solve my problem. 


i managed to see my data as numbers. i was looking to see my intensity graph instead 


i got a message on my browser saying (This XML file doesn't appear to have any style information associated with it. the document trees is shown below). 



anyone can help me to understand what's going on in my VI and why i can't display my intensity graph. 


please check the error message and what i'm looking to achieve. 





0 Kudos
Message 4 of 4