LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Web Service Error during "Publish" Application Web Server

Solved!
Go to solution

Hi All,

 

I have an error during Web Service "Publish" as attached screen shot.

My goal to connect with Labview NXG Web Module once "Publish" succeed. Please someone help me & advice for the error.

 

FYI, I am using Labview 2014 32bit running on Win10 64bit

0 Kudos
Message 1 of 4
(148 Views)

This might be overly simple but maybe try closing out of LabVIEW and rebooting. The error suggests that the file mentioned is already loaded into memory/and can't be copied to that location: "A LabVIEW file from that path already exists in memory, or exists within a project library already in memory."

 

Error copying files.
Source: C:\NI Week Demo Source Code\2019_CG_WebServices\WSsupport\Check if Session Exists.vi
Destination: C:\Users\ptpmsufi\AppData\Local\Temp\lvtemporary_144157.tmp\internal.llb\Check if Session Exists.vi

Invoke Node in AB_Source_VI.lvclass:Set_VI_Path.vi->AB_Source_VI.lvclass:Copy_SourceItem.vi->AB_Build.lvclass:Copy_Files.vi->AB_Build.lvclass:Build.vi->AB_RESTfulWebService.lvclass:Build.vi->AB_API Do Two Step Build.vi:4020001->AB_API Build.vi:4700001->NI_AB_API_Build.lvclass:Build.vi->NI_AB_API_RESTful.lvclass:Build.vi->NI Web Service Build.lvlib:Build Web Service.vi:3720001->NI Web Service Build.lvlib:Create_Rest.vi->NI Web Service Build.lvlib:Create_Rest.vi.ProxyCaller
<APPEND>
Method Name: <b>Set Path</b>
<Call Chain>Error 1357 occurred at AB_Source_VI.lvclass:Copy_SourceItem.vi -> AB_Build.lvclass:Copy_Files.vi -> AB_Build.lvclass:Build.vi -> AB_RESTfulWebService.lvclass:Build.vi -> AB_API Do Two Step Build.vi:4020001 -> AB_API Build.vi:4700001 -> NI_AB_API_Build.lvclass:Build.vi -> NI_AB_API_RESTful.lvclass:Build.vi -> NI Web Service Build.lvlib:Build Web Service.vi:3720001 -> NI Web Service Build.lvlib:Create_Rest.vi -> NI Web Service Build.lvlib:Create_Rest.vi.ProxyCaller

Possible reason(s):

LabVIEW:  A LabVIEW file from that path already exists in memory, or exists within a project library already in memory.
0 Kudos
Message 2 of 4
(112 Views)

Hi fblerg,

Thanks for the reply.

Yes, I also thought same with you, done reboot & below steps but the error still same.

Now I try checking each vi.

- close LabVIEW

- delete all the folders starting with "lvtemporary" located       at C:\Users\ptpmsufi\AppData\Local\Temp

- open LabVIEW

- clear the compiled cache (Tools»Advanced»Clear Compiled Object Cache)

- try to build again

0 Kudos
Message 3 of 4
(105 Views)
Solution
Accepted by topic author Yan_Sufian

Hi fblerg,

I have found the solutions for below error.

It happen on my created sub.vi "Check if Session Exists.vi" itself where I am using "Check if session Exists.vi" in vi library on the sub.vi (same name). I have rename my sub.vi & error solved.

Message 4 of 4
(99 Views)