LabVIEW

cancel
Showing results for 
Search instead for 
Did you mean: 

Waveform graph zoom while running/updating

Highlighted

Hi guys,

I have a small question regarding waveform graph zooming while a VI is running.
The waveform is mainly for monitoring our machine while it is running for hours and days (real time x-axis).

So the waveform is inside the sampling loop.

When I use the graph palette and turn the auto axis off (manually or property node), the zoom works quit nice!
But as soon as the graph is updated by new data it zooms to such an area, that the new data is shown as well.

Following example:

Full range on the x-scale is 11:00 - 13:00. I zoom in into 12:15-12:30. Let’s assume I gather data every minute.

As soon as the graph receives new data it will zoom to 12:46 to 13:01.

 

Sure I can set hard edge x- axes range with the property node, but this depends strongly on my zoom?

Any idea how to solve that problem elegantly?

Cheers
Fran

 

0 Kudos
Message 1 of 6
(1,544 Views)
Turn off autoscaling. Then you can set the axis to whatever you want.

Mike...

Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 2 of 6
(1,542 Views)

That is not very helpful...

I dont want to set the axis manually. It should just stay the same once I zoomed in and should not move while it receives new data.
Auto scale is off...

0 Kudos
Message 3 of 6
(1,518 Views)
If autoscaling is off, it won't move when new data is received.

Mike...

Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 4 of 6
(1,515 Views)
PS: zooming does change the axis range manually.

Mike...

Certified Professional Instructor
Certified LabVIEW Architect
LabVIEW Champion

"... after all, He's not a tame lion..."

For help with grief and grieving.
0 Kudos
Message 5 of 6
(1,513 Views)

Please have a look at the attached VI.

If you run it for some seconds and then try to zoom while the loop is running, it will change the x axis even if your turn off auto axis. Is it possible to "stop" the axis from continuously moving when I am zooming in?

0 Kudos
Message 6 of 6
(1,506 Views)