cancel
Showing results for 
Search instead for 
Did you mean: 
Reply

Waveform chart not changing with time

Solved!
Go to solution
Highlighted

Waveform chart not changing with time

Hi all,

 

I attached the VI I am working on. I have made no progress with the VI after watching some tutorials and reading. I have probed the input to the waveform chart and it is simply not chaning with time (x-axis). What do I need to do? Y data is working great.

0 Kudos
Message 1 of 11
(345 Views)

Re: Waveform chart not changing with time

Where is the waveform chart?  You have a meter and a numeric indicator.  No chart.

0 Kudos
Message 2 of 11
(342 Views)

Re: Waveform chart not changing with time

ummmm... pretty sure it is there in the block diagram. I think my problem is timing the while loop. I just have no idea how the whole labview timing thing works.

0 Kudos
Message 3 of 11
(329 Views)

Re: Waveform chart not changing with time


bronco9588 wrote:

ummmm... pretty sure it is there in the block diagram. I think my problem is timing the while loop. I just have no idea how the whole labview timing thing works.



A Waveform chart is an indicator that displays a historical set of values.  It resides on the Front Panel.  It will have an associated terminal on the block diagram.  Ummmm.... Pretty sure there is no Waveform chart in the attached vi.  Did you attach the one you meant to attach?

0 Kudos
Message 4 of 11
(324 Views)

Re: Waveform chart not changing with time

okay... so I attached the wrong VI. Sighs...

0 Kudos
Message 5 of 11
(321 Views)

Re: Waveform chart not changing with time

Silly DDT!  (Man those blue wires cause problems!)

Message 6 of 11
(312 Views)

Re: Waveform chart not changing with time

1) Can you backwards convert to labview 10.0.1 or earlier?

 

2) Is there a color coding schematic for wires? It would be very helpful.

0 Kudos
Message 7 of 11
(310 Views)

Re: Waveform chart not changing with time

My guess is that your data is out of range and simply does not show up since you have Y-axis Autoscaling turned off.  If the Mean is 1, the value fed to the chart is -211000.

 

Put an indicator (chart?) on the DAQ Assistant output.  Run the VI and acquire some typical data. Make the data in the indicator Default.  Save. Post that VI.  Then we can see you data and what is happening to it.

 

Also, 31 significant digits in Formula 2 is about 15 more than the VI will use.

 

Lynn

0 Kudos
Message 8 of 11
(309 Views)
Solution
Accepted by topic author bronco9588
08-27-2015 04:09 PM

Re: Waveform chart not changing with time

sorry bout that.  here it is in 2010

 

 

The dynamic data wires are the blue onses-  they can take almost any data - (Some of us older users despise them as much as express vis) hooking up a DDT directly to a Waveform Chart was your issue the WC expected the default DDT Datatype.  Converting to Scalar out of the mesurement express vi forced everyone downstream to accept that the data was just a simple DBL.

0 Kudos
Message 9 of 11
(301 Views)

Re: Waveform chart not changing with time

Thanks Dude. I am convinced express VIs exist to get people like me by and to keep guys like you busy. Go Flacko!

Message 10 of 11
(298 Views)